The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

Can't add texture layer to terrain

  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't add texture layer to terrain

    So I'm a relatively new UDK user, and still unfamiliar with a lot of the terms involved. I've been following the tutorials from (which is a fantastic reference for new users) and from (which has been a lot more difficult for me). I'm trying to learn how to do terrain in UDK from the latter source, and having some difficulty.

    Following the terrain tutorial (, I was able to go through all the different texture tools just fine - I can produce a terrain surface with bumps, valleys, hills, etc. The terrain strangely did not produce a default texture when created like the guide indicated, and the checkerboard remained 2x2 even when the total surface area expanded to 64x64, but those were minor problems.

    The main problem I am having is that, when I get to the step where I am supposed to add texture layers, it doesn't work. I've tried two approaches. Here's the first.

    I perform the "New Terrain Setup Layer from material (auto-create)" command - I'm using M_UN_Rock_SM_Blackspire04snow. I get a window with fields for Package, Group, and Name. I type in M_UN_Rock_SM_Blackspire04snow as the name and leave the other fields unchanged, then click OK. I immediately get another identical window, and when I close it, I find that the layer has been added, but the terrain has not been visually changed at all, still covered in the checkerboard. No dice.

    The second approach:

    I perform the "New Terrain Setup Layer from material (auto-create)" command, still using M_UN_Rock_SM_Blackspire04snow. This time, I change the Package to "UN_Rock" and Group to "SM.Materials." I don't know if this is what I should be entering in these fields, but the tutorial indicated that some versions of UDK require that these fields be specified, and that was my best guess. When I try to click OK now, I get the error message "The requested operation cannot be performed on a cooked package." Not knowing what a cooked package is, I'm quite confused. No dice.

    So I'm rather stuck. In the first approach I can create the layer but it has no effect, and in the second approach I can't create the layer to begin with. I'm confused on how to proceed, and also on exactly how the breakdown of "packages" and "groups" works to begin with. Any help would be much appreciated. Thanks!

  • #2
    You were on the right track with your first approach as far as I can tell, but it sounds like you canceled out the second dialog which was to create a TerrainMaterial to hold the regular material you had selected. You have to have a TerrainLayerSetup which has a TerrainMaterial assigned to it which has a regular material assigned to it.

    You can also create these manually in the Content Browser and set them up there and then apply them to the Terrain in its properties or using one of the options from the context menu in the Terrain Editor.

    Also, another thing to keep in mind is that changes to materials applied to a terrain do not all automatically update. You need to press the recompile button (has a red RM on it) in the Terrain Editor to see some changes.


    • #3
      Thanks for the help.

      Unfortunately, I still can't seem to get it to work. I'll outline the steps I just tried.

      1) Selected my terrain, and selected M_UN_Rock_SM_Blackspire04snow in the generic browser.
      2) Opened the Terrain editing mode and, under the right-click menu, selected "New Terrain Setup layer from material (auto-create)
      3) I entered the name "TerrainLayerSetup1" for the Terrain Layer Setup.
      4) I entered the name "TerrainMaterial1" for the Terrain Material.
      5) After clicking okay, the terrain is still visually unaltered.
      6) I click the Recache Terrain Materials button (I assume this is what you were referring to). It asks me if I want to recache the terrain shaders, I say yes. The terrain is still visually unaltered.

      What makes me suspicious here is that, aside from selecting the terrain at the start, there's nothing in this procedure saying that the material I setup should be applied to that piece of terrain specifically, and I know that you can have multiple terrains within a level. That's probably the missing piece, but I don't know what the answer is. Or perhaps the list of entries beneath "HeightMap" is specific to that piece of terrain, and would change if I selected a different piece? I'm not sure.

      I should also note that - and this is new - whenever I load this level, I get the following load error message:

      "The following resources were not found when loading the map. Any references to them were set to NULL. Missing files: Can't find file for 'Package_2'"

      I don't know what Package_2 is, though, so this is still quite confusing.


      • #4
        RE: Package_2

        Every time that you create something in the editor, it'll store it in a generic package file named Package_X (Where X is a number) until you save your package.

        So, what this is saying is that some time in the past, you created something in the editor and then placed it into your level and then never saved the package under a proper name. Since those are temp packages that dissapear when you close the editor, whatever it was no longer exists for the level to reference.

        In order to keep the stuff you make, you 'must' choose a package name (And preferably a group name) to add it to a proper package and then save that package. As long as you type something in to the package name when you first create/import your asset, your generic Package_X will always be empty.

        If you type in the name of a package that does not exist, it'll create a new package for you with that name and place your new asset inside of it.