Announcement

Collapse

The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

Normal Map/UDK display issue

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Normal Map/UDK display issue

    Hi Epic Forums!

    I'm currently trying to work through an issue in the newest version of UDK. You'll find 2 pics below. I've taken a very ugly and pronounced texture and thrown it on a wall. From angle A, you'll see that it's displaying the normals correctly. However, when I rotate my camera around to the second angle the spec and diffuse disappear.

    After a couple of days trying everything I know how to do, it's still doing this. I've even started a new scene, rebuilt the material and put it on a bsp floor with one point light in the scene. I've double checked the normal maps, even inverted the green channel in case it was some weird issue with the bake, that did not help.

    I'm running windows 7x64bit with an ATI Radeon 4890. A fellow artist has been troubleshooting this with me in the newest version of UDK. He runs a different machine using a fairly new Nvidia card and gets the exact same issue on his end.

    Any insights into this? The issue occurs on static mesh and BSP and seems to only happen after building the entire scene, but of course I can't tell if that's where the issue is occurring or not.





  • #2
    It looks to me as if your normals are inverted, because shouldn't it be highlighted in the lower image and not the upper? I know you said you've tried to mess with the normal map channels, still feels wrong. It's very weird in any case.

    Comment


    • #3
      This happens with every single normal map, regardless of where it comes from (crazybump, baked in maya, xnormal, nvidia filter) or, what I invert in the green/red channels.

      Comment


      • #4
        What settings are you selecting when importing the normal maps? Make sure you're selecting TC_Normalmap or TC_NormalmapUncompressed. These compression settings change a few flags on import (and change how the texture is stored in the case of Uncompressed).

        The changed values should be: SRGB will be unchecked (False), and UnPackMin will be -1 for [0], [1], and [2].

        Comment


        • #5
          Hey sorry to Hijack your thread (I came across it while searching due to the same problem) but are you going off of the Saitama storm sewers for inspiration??? I am currently working on a piece off of that and this is me redoing my original piece so it's my second time doing so haha!

          Comment

          Working...
          X