Announcement

Collapse
No announcement yet.

UDK/UT3 Video Tutorials List and Support Thread

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    I followed the video and exported my gun via actorx. I got the following errors.
    Node without matching vertices encountered for mesh: [Box03]
    Node without matching vertices encountered for mesh: [Box05]
    Warning: 333 'Unmatched node ID' Physique skin vertex errors encountered
    Unsmooth groups processing: [1641] vertices added
    Skin file GUNEXPORT.PSK written

    When I import the psk to udk I get message
    "Warning skeletal mesh is has no vertex influences"
    And as you can see in guninudk.jpg. Half the gun isn't there.

    Whats difference between your gun in the video and my gun in the pic below?
    I dont understand whats with all the green triangles. Are they supposed to be bullets. If so I already have projectile set up in my projectile factory kismet code.
    Attached Files

    Leave a comment:


  • replied
    come on guys, i don't want to spoon feed you your game content, to create your psa files make your anims then with the mesh selected export your anims via actorx, in the actorx manager then copy over and save the anims as a psa file, its the exact same way as doing the anims for the weapons


    if you're still unsure you can also find lots of videos on youtube like this one i just found http://www.youtube.com/watch?v=TmxXx...eature=related

    Leave a comment:


  • replied
    Originally posted by geodav View Post
    @azl, ok sounds like your using a custom mesh/rig for which you would have to create a custom animtree, anyway to create custom/extra anims just create the anim as normal and export it via actorx, i show this in my weapons tutorials its the same workflow just make sure you only have the mesh selected when you export the anims
    I have the same problem with Azl, I'm pretty confuse getting .psa file, specially for character not for weapon. I've tried exporting .psa from .max model from UT3, I've tried your video tutorial about weapon too, but it didn't work. Do you have some examples .psa file especially for character ?

    Leave a comment:


  • replied
    Originally posted by geodav View Post
    @azl, ok sounds like your using a custom mesh/rig for which you would have to create a custom animtree, anyway to create custom/extra anims just create the anim as normal and export it via actorx, i show this in my weapons tutorials its the same workflow just make sure you only have the mesh selected when you export the anims
    Ok, I've seen your tutorial about weapon. It's same problem, i don't have any .psa file to set the movement/anim for my character. Do you have some examples .psa file which is imported in video tutorial?

    Leave a comment:


  • replied
    @azl, ok sounds like your using a custom mesh/rig for which you would have to create a custom animtree, anyway to create custom/extra anims just create the anim as normal and export it via actorx, i show this in my weapons tutorials its the same workflow just make sure you only have the mesh selected when you export the anims

    Leave a comment:


  • replied
    Dear Geodav,

    I've followed your tutorial on "How to set your character as your Player". I've got a problem which is my character couldn't do any things (as jump,walk,etc). I think it doesn't works properly because I don't have a file .psa to solve this problem.
    Do you have any tutorial to make a .psa file, so we can set some movements to my own character?

    Leave a comment:


  • replied
    I'll try and make a video if I've got the time. Gotta lot going on with our project right now =)
    I'm not completely sure what we did with the bones to get it working by the way. What I wrote earlier was just my quick assumption of what the guy modeling the boat had done. Could be wrong =)

    Leave a comment:


  • replied
    video please MrArgh if your allowed

    Leave a comment:


  • replied
    Alright, we finally got it working through a lot of trial and error! You are completely correct regarding the base bone - that was the one we animated because we needed everything to move.
    We've added another bone betweed the base and all the others and it's working as intended.

    Thanks a lot for your time and help geodav!

    Leave a comment:


  • replied
    ok for anims to work you need a bone between your base bone and the one you want to animate (watch my weapon tutorials) afaik you can't animate the base bone to get that to do anything you'll have to code it direct which is way over my head

    Leave a comment:


  • replied
    Thanks for the pic - looks like I've got it set up like that though. I'm wondering if the collision on my vehicle could be the problem? Going to try and change that.

    Edit: Alright, I've made a bit of progress. I can start an animation that moves another bone up/down. However when I want to use my regular animation (that rotates the base bone) nothing happens. I've tried reducing both gravity and wheel suspension - with no success.

    Leave a comment:


  • replied
    @azl here's the link http://www.gamefront.com/files/20260...p_Tutorial.avi it's on my old filefront set up but will move it to fileplanet when they fix the upload

    Leave a comment:


  • replied
    sure give me a day or to to set things up

    Leave a comment:


  • replied
    Originally posted by geodav View Post
    @azl, well i don't know how to add/capture objects into your minimap but i do know how to get the texture of the map into game to use as a background for the minimap if that is any help, if that what you need then let me know and i#ll do you a video
    That's OK.. I don't know how to get the texture of the map into game to use as a background for the minimap.. Can you show me as a video tutorial?

    Leave a comment:


  • replied
    ok i'm not sure if i used a UDKAnimNodeSequence or a UTAnimNodeSequence on this vehicle but here's a pic anyway of the basic setup



    Uploaded with ImageShack.us

    Leave a comment:

Working...
X