Announcement

Collapse

The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

UDK/UT3 Video Tutorials List and Support Thread

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Thats strange.
    You could try redownloading the package.

    Is it the VH_LandTank.upk
    size; 38,544 KB

    Comment


      ok try these settings


      Uploaded with ImageShack.us

      using maya will make things a little harder for you but you need to try and align the bone/pivots correctly before skinning to the mesh

      @UFO, i've just downloaded the content and tried it and it works fine

      Comment


        it must be some simple issue again
        because the content appears in the content browser and even the the texture's images are displayed ! but the name of the package in the list is black and if i either try to open , configure the content or fully load the package , it crashes.

        i checked the file i have is the same exact size.

        Comment


          sorry for the double post but check this out from my log file :

          Code:
          [0065.51] Log: === Critical error: ===
          ReadFile beyond EOF 39468147+2/39468147 for file C:\UDK\UDK-2011-06\Binaries\Win64\..\..\UDKGame\Content\Vehicles\Geo\VH_LandTank.upk
          
          Address = 0xfd44aa7d (filename not found) [in C:\Windows\system32\KERNELBASE.dll]
          Address = 0x40261505 (filename not found) [in C:\UDK\UDK-2011-06\Binaries\Win64\UDK.exe]
          Address = 0x4021d698 (filename not found) [in C:\UDK\UDK-2011-06\Binaries\Win64\UDK.exe]
          Address = 0x40187d87 (filename not found) [in C:\UDK\UDK-2011-06\Binaries\Win64\UDK.exe]
          Address = 0x40203a46 (filename not found) [in C:\UDK\UDK-2011-06\Binaries\Win64\UDK.exe]
          Address = 0x401c36b4 (filename not found) [in C:\UDK\UDK-2011-06\Binaries\Win64\UDK.exe]
          Address = 0x401f837a (filename not found) [in C:\UDK\UDK-2011-06\Binaries\Win64\UDK.exe]
          Address = 0x4023c3d2 (filename not found) [in C:\UDK\UDK-2011-06\Binaries\Win64\UDK.exe]
          Address = 0x4024530c (filename not found) [in C:\UDK\UDK-2011-06\Binaries\Win64\UDK.exe]
          Address = 0x4088a5a5 (filename not found) [in C:\UDK\UDK-2011-06\Binaries\Win64\UDK.exe]
          Address = 0x4020637a (filename not found) [in C:\UDK\UDK-2011-06\Binaries\Win64\UDK.exe]
          Address = 0x4025bb97 (filename not found) [in C:\UDK\UDK-2011-06\Binaries\Win64\UDK.exe]
          Address = 0x4025ce63 (filename not found) [in C:\UDK\UDK-2011-06\Binaries\Win64\UDK.exe]
          Address = 0xf85dcf42 (filename not found) [in C:\Windows\Microsoft.NET\Framework64\v2.0.50727\mscorwks.dll]
          Address = 0x3651a1   (filename not found) 
          Address = 0xffc76b00 (filename not found) 
          Address = 0x52cf18   (filename not found) 
          Address = 0x478f0d8  (filename not found) 
          Address = 0x52cbd8   (filename not found) 
          Address = 0x20000    (filename not found) 
          Address = 0x20000    (filename not found) 
          System.Runtime.InteropServices.SEHException error in UDK:
          
          External component has thrown an exception.
          
             at UObject.StaticLoadObject(UClass* , UObject* , Char* , Char* , UInt32 , UPackageMap* , UInt32 )
             at MContentBrowserControl.LoadSelectedObjectsIfNeeded()
             at MContentBrowserControl.LoadAndActivateSelectedAssets()
             at ContentBrowser.AssetCanvas.AssetVisual_MouseDoubleClick(Object sender, MouseButtonEventArgs e)
             at System.Windows.RoutedEventArgs.InvokeHandler(Delegate handler, Object target)
             at System.Windows.EventRoute.InvokeHandlersImpl(Object source, RoutedEventArgs args, Boolean reRaised)
             at System.Windows.UIElement.RaiseEventImpl(DependencyObject sender, RoutedEventArgs args)
             at System.Windows.Controls.Control.OnMouseDoubleClick(MouseButtonEventArgs e)
             at System.Windows.Controls.Control.HandleDoubleClick(Object sender, MouseButtonEventArgs e)
             at System.Windows.RoutedEventArgs.InvokeHandler(Delegate handler, Object target)
             at System.Windows.EventRoute.InvokeHandlersImpl(Object source, RoutedEventArgs args, Boolean reRaised)
             at System.Windows.UIElement.ReRaiseEventAs(DependencyObject sender, RoutedEventArgs args, RoutedEvent newEvent)
             at System.Windows.UIElement.OnMouseDownThunk(Object sender, MouseButtonEventArgs e)
             at System.Windows.RoutedEventArgs.InvokeHandler(Delegate handler, Object target)
             at System.Windows.EventRoute.InvokeHandlersImpl(Object source, RoutedEventArgs args, Boolean reRaised)
             at System.Windows.UIElement.RaiseEventImpl(DependencyObject sender, RoutedEventArgs args)
             at System.Windows.UIElement.RaiseEvent(RoutedEventArgs args, Boolean trusted)
             at System.Windows.Input.InputManager.ProcessStagingArea()
             at System.Windows.Input.InputManager.ProcessInput(InputEventArgs input)
             at System.Windows.Input.InputProviderSite.ReportInput(InputReport inputReport)
             at System.Windows.Interop.HwndMouseInputProvider.ReportInput(IntPtr hwnd, InputMode mode, Int32 timestamp, RawMouseActions actions, Int32 x, Int32 y, Int32 wheel)
             at System.Windows.Interop.HwndMouseInputProvider.FilterMessage(IntPtr hwnd, Int32 msg, IntPtr wParam, IntPtr lParam, Boolean& handled)
             at System.Windows.Interop.HwndSource.InputFilterMessage(IntPtr hwnd, Int32 msg, IntPtr wParam, IntPtr lParam, Boolean& handled)
             at MS.Win32.HwndWrapper.WndProc(IntPtr hwnd, Int32 msg, IntPtr wParam, IntPtr lParam, Boolean& handled)
             at MS.Win32.HwndSubclass.DispatcherCallbackOperation(Object o)
             at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Boolean isSingleParameter)
             at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Boolean isSingleParameter, Delegate catchHandler)
             at System.Windows.Threading.Dispatcher.InvokeImpl(DispatcherPriority priority, TimeSpan timeout, Delegate method, Object args, Boolean isSingleParameter)
             at MS.Win32.HwndSubclass.SubclassWndProc(IntPtr hwnd, Int32 msg, IntPtr wParam, IntPtr lParam)
             at GuardedMainWrapper(Char* , HINSTANCE__* , HINSTANCE__* , Int32 )
             at ManagedGuardedMain(Char* CmdLine, HINSTANCE__* hInInstance, HINSTANCE__* hPrevInstance, Int32 nCmdShow)

          Comment


            just re-build the upk and checked it in UDK 08/2011

            http://www.gamefront.com/files/20748668/VH_LandTank.upk

            hope it helps

            Comment


              hello again, I cannot solve my problem with steering, just can't find what to change in my code, But I have one more question, how can I change the max speed of my cars?? so each of them can have diferrent properties, I tried with the groundspeed option but it didn't seem to make any change.

              Sorry to ask so many questions, But I find to hard the way to create vehicles, thanks for the help

              Comment


                i'd try

                Code:
                	GroundSpeed=800
                	AirSpeed=950
                	MaxSpeed=1050
                apart from that no idea

                as for the steering problem it's hard to second guess without actually see the code+content, if you upload it somewhere and PM me a link then i'll have a look for you

                Comment


                  Hello, as you asked me, I recorded in video some of my issues with my car, as you can see in the first seconds when I try to turn left or right at low speed the car turns unnaturally I think is some issue with the steering, second when I use the boot of the car, two of the wheels go up in a weird effect.

                  Also I get some sounds and an error that comes al the time, like of the cars was charshing continiuly all the time, I show the error at the end of the video, where I show you the log console of the game.

                  I hope that with this video you could help me with the little issues I still have with my cars, thanks for the help, you are always so helpfull

                  Comment


                    looks like it has no grip for the steering problem
                    LatSlipFactor in the wheel code

                    the way i stopped the wheels going up all spaz like that was to comment out these lines here, nothing else seemed to work
                    Code:
                    /**
                    when called makes the wheels stick to the ground more
                    */
                    simulated function LockWheels()
                    {
                    	local SVehicleSimCar SimCar;
                    
                    	bSteeringLimited = true;
                    	SimCar = SVehicleSimCar(SimObj);
                    
                    	//Wheels[0].SuspensionTravel = LockSuspensionTravel;
                    	//Wheels[1].SuspensionTravel = LockSuspensionTravel;
                    	//SimCar.WheelSuspensionStiffness= LockSuspensionStiffness;
                    	SimCar.MaxSteerAngleCurve.Points[0].OutVal = BoostSteerFactors[0]; //10.0;
                    	SimCar.MaxSteerAngleCurve.Points[1].OutVal = BoostSteerFactors[1]; //4.0;
                    	SimCar.MaxSteerAngleCurve.Points[2].OutVal = BoostSteerFactors[2]; //1.2;
                    
                    }

                    hope you dont mind geodav

                    Comment


                      The tires going up on the power up a re fixed, thank you guys

                      sorry I changed the latslipfactor fo both wheels on my Vehicle code and on my wheel class but doesn't have any effect on my car, The slipfactor has to be between some values to work normallly???
                      here is my Vehicle code
                      Code:
                      Begin Object Class=RaceKartWheel Name=FLWheel
                              BoneName="F_L_Tire"
                              BoneOffset=(X=0.0,Y=20.0,Z=-2.0)
                              SteerFactor=1.0
                              LongSlipFactor=2.0
                              LatSlipFactor=7.5
                              HandbrakeLongSlipFactor=0.6
                              HandbrakeLatSlipFactor=0.8        
                              SkelControlName="FLTire"
                          End Object
                          Wheels(2)=FLWheel
                      my wheel class

                      Code:
                      class RaceKartWheel extends UDKVehicleWheel;
                      
                      defaultproperties
                      {
                          WheelRadius=22
                          SuspensionTravel=0
                          bPoweredWheel=true
                          SteerFactor=0.0
                          LongSlipFactor=5.0
                          LatSlipFactor=2.75
                          HandbrakeLongSlipFactor=0.7
                          HandbrakeLatSlipFactor=0.3
                          ParkedSlipFactor=10.0
                          bUseMaterialSpecificEffects=true
                      }

                      Thanks to your help to both of you guys, If I finish soon my game swear I'm gonnna put you on the credits, Thanks Guys

                      Comment


                        i usually have slipfactor between 1.0 and 3.0, so 7.5 should be really grippy.
                        so it must be
                        MinHardTurnSpeed=99999.0 //never hard turn

                        and/or
                        MaxSteerAngleCurve, it makes you turn less at higher speeds

                        this works for me
                        MaxSteerAngleCurve=(Points=((InVal=0,OutVal=25),(I nVal=600.0,OutVal=20.0),(InVal=3100.0,OutVal=16.0) ,(InVal=4400.0,OutVal=12.0),(InVal=5000.0,OutVal=9 .0)))

                        edit:
                        just noticed i have these values too

                        SteeringReductionFactor=0.0
                        SteeringReductionMinSpeed=9999.0
                        SteeringReductionSpeed=9999.0

                        Comment


                          @tegleg, your most welcome to help at any time

                          on a side note for all those who want to use Blender with UDK i'm start a video tutorial set in which i'll be learning/showing how to get your content from Blender to udk, you can check these out on my youtube blender play list
                          http://www.youtube.com/user/ut40kgeo...505CB05DD96D36

                          Comment


                            Thank you very much geodav these set of videos will help me a lot


                            Edit :

                            Setting up the AnimTree for the HoverCraft in Unreal Ed

                            Setting up the Code for the HoverCraft in Context

                            Testing the HoverCraft in UT3

                            Cooking the HoverCraft package

                            Could not download above videos from GameFront says file not found

                            Comment


                              Hi,
                              Thanks so much for your tutorials. Its been really helpful.
                              I've watch your video UDK_Character_05_Player_Coding_a.avi and everything is great, but now my udk crashes after a few minutes into the game when I'm like shooting the enemies. Is there anyway to solve this?

                              I did a short video to show you the problem. Its quite laggy so sorry about that.

                              http://www.youtube.com/watch?v=-3LR0DyzdsQ&

                              EDIT: I just realize that when I first got into the game, the bot would shoot at me, after awhile it will just stop and not shoot. At this point nothing happens. But the moment I try to shoot at the bot or when either one of us is to get killed, UDK Game crashes. If I were to shoot at nothing, it doesn't crash at all. Am I doing something wrong?

                              Also thanks for directing me to here regarding the UTrigs, but is there anyway I can open a 3DMax file in Maya? I've googled and most of the answers I've found are telling me it can't be open. Is there another way to get the rigs(Maya)?

                              Anyway, thanks again in advance.

                              I'm unable to embed the video as the resolution is quite big and I'm not sure how to change from here.

                              Comment


                                see you never said you wanted the "maya" rig try Denny's http://forums.epicgames.com/threads/...Animation-Rigg

                                ok when you get crashes or errors check your launch.log (UDK-2011-09\UDKGame\Logs) if it doesn't make any sense to you then post it here but don't forget to use "Go Advanced" and use the "code" tag

                                Comment

                                Working...
                                X