Announcement

Collapse

The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

UDK/UT3 Video Tutorials List and Support Thread

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

    ok take a tip from me, watch my videos, make you own weapon first, learn how to use 3ds max, then try again.

    the thing called group is you weapon, it is a "Group" mesh eg lots of parts "grouped" together you need to ungroup it then attach all the parts together, in the "select by name lister" (hotkey H) make sure you can see everything you may have switched something off

    Comment


      Offline developers need an offline reference zip of udk docs

      Thanks to everyone who posts tutorials and example files about the UDK

      I switched to UDK from valve recently


      I am offline
      all of you good folks are probably permanently connected with high speed umbilicals
      I get about 3 hours max at the library

      I really need an offline html of the entire udk dox wiki

      By now some bright human must have already gathered all the pages and zipped them so they wouldn't have to dl them again

      can someone link me to such a repository of useful study material?

      video tuts aren't what I really need, the udk dox are getting pretty complete
      but what's with the online only format.

      I'm looking forward to improvements in an already very robust dev environment.

      Comment


        @Anartist you may not have noticed that on the UDK doc site "UDN" it states that people should "NOT" make an offline version.

        i on average get ca 2 hour per day on a computer - to do my game - to do tutorials - to help on this forum - and to have fun - but i do have a fast-ish connection

        Comment


          Really enjoying the tutorials ive seen so far, the 40K stuff is awesome, great stuff!

          Comment


            I'm following your videos for setting up the folders and making the gametype, but I've run into two problems.

            First, in my UTGame.uc file, I don't have this section that is in your video:

            "DefaultMapPrefixes (0) = (Prefix="DM",GameType="UTGame.UTDeathmatch")
            DefaultMapPrefixes (1) = (Prefix="CTF",GameType="UTGameContent.UTCTFGame_Co ntent")
            DefaultMapPrefixes (3) = (Prefix="VCTF",GameType="UTGameContent.UTVehicleCT FGame_Content")"


            Secondly, when you run the Game at the end of video 2, where yours says, "GeoDeathmatch" mine comes out saying, "DavCorp.GeoDeathmatch"


            Where am I going wrong?

            Comment


              your not going wrong at all, when i recorded those video's (12.2009) that was all correct, since then there have been changes to the UDK code including the UTGame code witch is why those lines are no longer there.

              the change in the gametype name comes from that UDK now uses the scaleform frontend (menu) which for some reason shows the game package as well, don't worry it does it to me, if i find an answer to it then i'll let you all know.

              i last checked my code and content with the March2011 UDK release so you should be ok

              Comment


                Originally posted by geodav View Post
                your not going wrong at all, when i recorded those video's (12.2009) that was all correct, since then there have been changes to the UDK code including the UTGame code witch is why those lines are no longer there.

                the change in the gametype name comes from that UDK now uses the scaleform frontend (menu) which for some reason shows the game package as well, don't worry it does it to me, if i find an answer to it then i'll let you all know.

                i last checked my code and content with the March2011 UDK release so you should be ok
                Ah, okay.

                I've come across a new problem: after finishing the basic game, when I go to choose settings (bots, etc.) there is nothing there so it defaults to a bot on each spawn point.

                Comment


                  ok to get the menu settings to work with the udk scaleform menu system you need to add the following in your UDKGame.ini

                  Code:
                  [UT40kDeathmatch UTUIDataProvider_GameModeInfo]
                  GameMode=UT40k.UT40kDeathmatch
                  GameSettingsClass=UTgameSettingsDM
                  GameSearchClass=UTGameSearchDM
                  PreviewImageMarkup=UT40k_UI_Materials.GameTypes.UT40k_GametypePic_Default
                  DefaultMap=UT40kDM-ut40ktest_10
                  Prefixes=UT40kDM
                  OptionSet=UT40kDM
                  IconImage=UI_HUD.HUD.UI_HUD_BaseD
                  IconU=442
                  IconV=76
                  IconUL=129
                  IconVL=104
                  FriendlyName=UT40k_Deathmatch
                  Description=Free-for-all deathmatch action.
                  and

                  Code:
                  [BotSkill_DM UTUIDataProvider_MenuOption]
                  OptionSet=DM
                  OptionSet=TDM
                  OptionSet=VCTF
                  OptionSet=UT40kDM
                  OptionSet=UT40kTDM
                  DataStoreMarkup=<UTGameSettings:BotSkill>
                  
                  [NumBots_DM UTUIDataProvider_MenuOption]
                  OptionSet=DM
                  OptionSet=TDM
                  OptionSet=VCTF
                  OptionSet=UT40kDM
                  OptionSet=UT40kTDM
                  DataStoreMarkup=<UTGameSettings:NumBots>
                  OptionType=UTOT_Slider
                  RangeData=(MinValue=0.0,MaxValue=15.0,bIntRange=1,NudgeValue=1.0,CurrentValue=0.0)
                  
                  [VsBots_DM UTUIDataProvider_MenuOption]
                  OptionSet=TDM
                  OptionSet=VCTF
                  OptionSet=UT40kDM
                  OptionSet=UT40kTDM
                  DataStoreMarkup=<UTGameSettings:VsBots>
                  bOnlineOnly=1
                  
                  [GoalScore_DM UTUIDataProvider_MenuOption]
                  OptionSet=DM
                  OptionSet=TDM
                  OptionSet=VCTF
                  OptionSet=UT40kDM
                  OptionSet=UT40kTDM
                  DataStoreMarkup=<UTGameSettings:GoalScore>
                  bEditableCombo=1
                  bNumericCombo=1
                  
                  [TimeLimit_DM UTUIDataProvider_MenuOption]
                  OptionSet=DM
                  OptionSet=TDM
                  OptionSet=VCTF
                  OptionSet=UT40kDM
                  OptionSet=UT40kTDM
                  DataStoreMarkup=<UTGameSettings:TimeLimit>
                  bEditableCombo=1
                  bNumericCombo=1
                  
                  [BotTeam_DM UTUIDataProvider_MenuOption]
                  OptionSet=TDM
                  OptionSet=VCTF
                  OptionSet=UT40kDM
                  OptionSet=UT40kTDM
                  DataStoreMarkup=<UTStringList:BotTeams>
                  bRemoveOn360=1
                  bRemoveOnPC=1
                  bRemoveOnPS3=1
                  
                  [ForceRespawn_DM UTUIDataProvider_MenuOption]
                  OptionSet=DM
                  OptionSet=TDM
                  OptionSet=VCTF
                  OptionSet=UT40kDM
                  OptionSet=UT40kTDM
                  DataStoreMarkup=<UTGameSettings:ForceRespawn>
                  OptionType=UTOT_CollectionCheckBox
                  please note these are not the entries used in my DavCorp gametypes you just need to adjust the option in your gametype ini entry and then add it to the other MenuOption sections

                  Comment


                    Geodav, some of your tut's have been handy and have to say thanks. But old ones that don't work anymore maybe should be taken down (due to engine changes) maybe to help out new one's chasseing something that will never work with current engine configs. Update with the info above, would love to see footage of the game you’re working on!

                    Comment


                      to be honest i'm finding it hard to find the time to do much atm, i do realise that most of my tutorials are a bit dated, the main thing is the work flow and to get people thinking in the Unreal way of doing things, if i get time i may re-new the udk basics as they have changed the most over the last year. some of the info in this thread may not get into the videos as Epic has a nasty habbit of changing great freatures to stop "Modders" from using to much of the UTGame code

                      if you mean UT40k as the game i'm working on then just goto http://www.moddb.com/mods/ut40k-the-chosen and download the monthly build that i upload on the last day of every month (tomorrow evening)

                      Comment


                        Is there any way I can turn down the detail in UDK, not in editor. I mean in the actual game.

                        Comment


                          you can probley do it via postprocess effects but its not something i've looked at sorry

                          Comment


                            Hello there, I have seen Geodav tutorials and another ones over the web and I have some issues with my UDK Vehicle, I made mine in Blender and when I import it from a PSK file, add the anim tree but at the end my car comes to game with the front pointing to the sky, the wheels roll backguards and when I try to turn the car the steering whels are the ones in the back istead of the ones in the front, I think is somthing in my modeling program but I have trying for more than a month and can't figure how to solve this. Could any of you help me please?

                            I add images of my problem
                            [SHOT]http://saga-deluxe.net/img/carro.png[/SHOT]
                            [SHOT]http://saga-deluxe.net/img/carro2.png[/SHOT]

                            Comment


                              first try using small pics or the shot tag(looks like the UT3 icon)

                              ok most problems like this are caused by the orintation of the base bone(pivot) sorry i've no idea how to do that in blender but it has to be done before you skin the mesh to the rig

                              as for steer the wrong wheel most likely you got something mixed up in the code, eg which are the front wheel bone and which are the rear

                              Comment


                                Sorry for the big images, I just fixed that problem now,

                                about my wheel bones they are called F_R_Tire and F_L_Tire for the front ones and B_R_Tire and B_L_Tire for the one in the back, I'll check my code about that and ask the person that helps me with the 3D models about the orientation

                                Comment

                                Working...
                                X