Announcement

Collapse
No announcement yet.

[SOLVED] UILoader not working on Cooked Game

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [SOLVED] UILoader not working on Cooked Game

    In my mainmenu i have two UILoaders. Using UnrealScript i set the images like below and it works when playing the game but once i cook the game --> Install it and play, the UILoaders no longer works.

    Code:
    function BtnPress()
    {
        ImageOne = GetVariableObject("_root.UIImage1");
        ImageTwo = GetVariableObject("_root.UIImage2");
        ImageOne.SetString("source","img://GameMainMenu.UIImages.Image1");
        ImageTwo.SetString("source","img://GameMainMenu.UIImages.Image2");
    }
    In my DefaultEngine.ini file i added the GameMainMenu under PackagesToAlwaysCook.
    Code:
    [Engine.PackagesToAlwaysCook]
    +Package=EnvyEntry
    +Package=GameMainMenu
    After Cooking the game in Unreal Frontend i can see the CustomPackage folder with gamemainmenu_SF.upk inside it under my UDK Installation Folder\UDKGame\CookedPC\UT3. However when i package the game this CustomPackage is not included.

    Any idea on how to make the UILoader work in cooked game?

    #2
    I've had your problem. after adding my packages ( my scaleform swf + the package that load its Texture2D ) in these parts (below) of DefaultEngine.ini, my packages appears in after-install udk content folder.

    DefaultEngine.ini parts : ( I think I add more place that it needed )
    Code:
    [URL]
    MapExt=udk
    ; Any additional map extension to support for map loading.
    ; Maps without an extension always saved with the above MapExt
    AdditionalMapExt=mobile
    Map=s926_map.udk               <--------- MAP
    LocalMap=s926_map.udk
    TransitionMap=s926_map.udk
    EXEName=MyApplication.exe
    DebugEXEName=DEBUG-UTGame.exe
    
    [Engine.ScriptPackages]
    +NonNativePackages=UTGame
    +NonNativePackages=UTGameContent
    +NonNativePackages=S926                        <---------
    +NonNativePackages=S926_Resource               <---------
    
    [Engine.PackagesToAlwaysCook]
    +Package=EnvyEntry
    +Package=S926                         <---------
    +Package=S926_Resource               <---------
    
    [Engine.StartupPackages]
    +Package=FX_HitEffects
    +Package=UDKFonts
    +Package=UTGame
    +Package=S926                            <---------
    +Package=S926_Resource               <---------
    
    [Engine.PackagesToForceCookPerMap]
    .Map=UDKFrontEndMap
    .Package=UDKFrontEnd
    .Package=UI_FrontEnd_Art
    +Package=S926                            <---------
    +Package=S926_Resource                <---------
    MY PROBLEM:
    But after working my UILoader, It show Texture2Ds blur !!!! ( Any suggestion ?

    Comment


      #3
      WOW ! I Solve it !
      You should just disable Mip for Texture2D ( Although I Dont know what the hell that is )

      double-click Texture2D -> Mip Gen Setting -> "No Mipmaps" ( More info: http://iamsparky.wordpress.com/2011/07/12/mitmaps/ )

      I highly recommend to check "Dealing with texture compression issues" of this page : http://udn.epicgames.com/Three/ScaleformImport.html

      Comment


        #4
        Originally posted by emadpres View Post
        I've had your problem. after adding my packages ( my scaleform swf + the package that load its Texture2D ) in these parts (below) of DefaultEngine.ini, my packages appears in after-install udk content folder.

        DefaultEngine.ini parts : ( I think I add more place that it needed )
        Code:
        [URL]
        MapExt=udk
        ; Any additional map extension to support for map loading.
        ; Maps without an extension always saved with the above MapExt
        AdditionalMapExt=mobile
        Map=s926_map.udk               <--------- MAP
        LocalMap=s926_map.udk
        TransitionMap=s926_map.udk
        EXEName=MyApplication.exe
        DebugEXEName=DEBUG-UTGame.exe
        
        [Engine.ScriptPackages]
        +NonNativePackages=UTGame
        +NonNativePackages=UTGameContent
        +NonNativePackages=S926                        <---------
        +NonNativePackages=S926_Resource               <---------
        
        [Engine.PackagesToAlwaysCook]
        +Package=EnvyEntry
        +Package=S926                         <---------
        +Package=S926_Resource               <---------
        
        [Engine.StartupPackages]
        +Package=FX_HitEffects
        +Package=UDKFonts
        +Package=UTGame
        +Package=S926                            <---------
        +Package=S926_Resource               <---------
        
        [Engine.PackagesToForceCookPerMap]
        .Map=UDKFrontEndMap
        .Package=UDKFrontEnd
        .Package=UI_FrontEnd_Art
        +Package=S926                            <---------
        +Package=S926_Resource                <---------
        THAAAAAAAANKKKKKKKKKKKKKK YYYYYYYYYYYYOOOOOOOOOOOOUUUUUUUUUU.

        Thanks a million emadpres. This issue was driving me crazy for months and finally it worked. Million Thanks To You MAN!!!

        Comment

        Working...
        X