No announcement yet.

Fonts Disappear?

  • Filter
  • Time
  • Show
Clear All
new posts

    Fonts Disappear?

    We're encountering an odd glitch with our menu system. When you start the game, the menus all work fine - all text is displayed normally. However, when you join a game, then return to the menu, all the text is replaced with the glyph not found boxes.

    As far as I can tell, the font library is set up correctly, as is fontconfig, fonts_en, etc. on the Flash end. Could this possibly be related to not having a font imported into udk?

    Has anyone ran into this issue before, or have any idea how to fix it?

    More Info: After switching fonts and updating everything, and importing the font into udk, the main menu is displaying the "M" in "START GAME." I tried switching the label to "start game," which gives me "st te."

    Still very confused about this. Any Suggestions?


      Had something similar when UI elements swapped states.
      In one state, the correct font was being used.
      In the other, boxes galore.
      Had to go in and set the correct font each state.

      You could be having a similar issue - focused vs default for instance.


        Double checking, no, the fonts used in each state are the same; the error only appears after starting a game.

        Thank you though.


          Have you tried disabling auto-kern? I had encounter a problem before with my button's text turning into solid boxes and when I untick the auto-kern, the text turned normal.