Announcement

Collapse
No announcement yet.

CLIK Label not updating position after call to SetText("")

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    CLIK Label not updating position after call to SetText("")

    I have a Clik Label (AS2) on my custom HUD. I am extending GfxMoviePlayer. I am using this label as a Timer, so I update the time text roughly every tick. As well, in the Flash file I have the timer label move up in the scene after 3 seconds, along with a container graphic.

    If I do not attempt to set the text of the label everything works fine and animates correctly. However, if I set the Timer Label, it will not update its position as it is animated in the Flash file. The container graphic still works and animates up just fine.

    One work around (which I really don't want to do and assume is the wrong method) is that I can manually update the Timer Labels position from unrealscript using SetPosition. This is essentially just animating from Code and seems like a really silly thing to have to do considering its using flash.

    Has any one else encountered something similar or is there something Im missing about how flash timeline animation is executed in UnrealScript?

    #2
    Update (Still not working):

    I tried changing the text in the label through action script by calling an AS function from Unreal Script. Again, the same issue. The label stops updating its position. I've run very low on ideas but it seems to me that it would be pretty useless if labels could not have their text string updated. This is making it very hard for me to implement menus. Any suggestions would be most appreciated!

    Comment


      #3
      FIXED:

      Well sort of, I switched over to ActionScript 3.0 and using the new system it works fine. I am using now a standard text field as well rather than a CLIK label.

      I followed this method: AS3 - Setting up Non-CLIK TextFields

      Comment

      Working...
      X