No announcement yet.

Scaleform 4/AS3 - Sandbox Files

  • Filter
  • Time
  • Show
Clear All
new posts

    Scaleform 4/AS3 - Sandbox Files

    Here's a download link to a simple Scaleform 4/AS3-based menu and HUD for those of you just starting out with UDK & Scaleform. All source files are included, including UnrealScript, Flash, ActionScript Classes, Map, DLL, INI, and Package files.

    NOTE: These files have been tested to work; however, use at your own risk. These are not officially supported files by Epic or Autodesk, and are not intended to serve as a tutorial.

    These files currently demonstrate how to:
    • Create a simple menu which loads a test level when the Start button is pressed.
    • Create an animated mouse cursor with tool tip roll-overs.
    • Use CLIK widgets.
    • Localize text.
    • (HUD) Inject an AS3 document class into a Flash file & work with public variables.
    • (HUD) Toggleable mouse cursor (hold Left Shift to toggle).
    • (Feb 2012 UDK Only)(HUD) Using DLLBind to set the position of the mouse.
    • (March 2012+ UDK)(HUD) Using SetMouse() to set the position of the mouse.

    [March 2012 UDK] Download the Files
    [February 2012 UDK] Download the Files

    You can simply extract the zip into your base UDK install folder; however, doing so will overwrite three files:


    If you prefer, compare these files with your original UDK files, and make the changes manually. The changes are:





    PlayerControllerClassName=SFTutorialAS3.SFAS3Playe rController

    +DefaultMapPrefixes=(Prefix="SFAS3",bUsesCommonPac kage=FALSE,GameType="SFTutorialAS3.SFAS3Game")


    .Bindings=(Name="LeftShift",Command="ToggleMouseCu rsor true | Onrelease ToggleMouseCursor false")

    I was wait for this!



      Can't find file for package 'SFTutorial' while loading C:\UDK\UDK-2012-05BASE\UDKGame\Content\Maps\SFTutorials\SFAS3-Menu.udk

      I am using the March version on May UDK. Shouldn't this still work?

      All I get is a black screen with a Start Game and Options buttons, If I choose Start Game I get no HUD or visible map.


        I downloaded the March UDK. Still no HUD, map, or anything other that a black background.

        Has anyone got this to work? It seems pretty straight forward, don't see what I could be doing wrong.


          hi ...
          if can you create ammo , health , compass & other things sample in AS3 HUD it's very useful for us to have vision from that .....


            where i must add these code ???



              This doesn't work as advertised, at least for the March version. The sample map will not start, making any HUD useless.

              As this is a beginner tutorial/example for Scaleform, it is extra frustrating for it not to work correctly.


                Originally posted by Prezadent View Post
                This doesn't work as advertised, at least for the March version. The sample map will not start, making any HUD useless.

                As this is a beginner tutorial/example for Scaleform, it is extra frustrating for it not to work correctly.
                These are sample files, that do in fact work, and are tested to work. This was provided as is, and not as an official tutorial. If you want official tutorials, please see the Scaleform video tutorials that will walk you through learning how to use Scaleform.


                  and where we find the scaleform video tutorials? :-)


                    Read the Getting Started forum sticky post for links.


                      I got this to work just fine using Nov 2012 beta. My folder says UDK-2012-10 for whatever reason. I looked for October but all I see is November and I downloaded it a couple weeks ago.

                      Anyway, I tried unzipping straight into the directory but it didn't work. Maybe I did it wrong, or something to do with permissions. You have to make sure you put all the files into their proper folders, change all the necessary stuff in the ini files, full recompile, then once in the UDK choose Play On PC button (not play in editor), otherwise you will just get a black screen if you try to play the game. Play in Editor does not allow maps to be loaded, whereas Play on PC does.

                      Edit: Unfortunately, I can't examine the .fla files. Says "unexpected file format" even though I'm using Flash CS4 Professional.


                        Hello Mr Doyle,

                        I am trying to use 3Di extentions using UDK. I can't get proper documentation or pipeline (even @ )
                        There are no 3d samples included (or they are very well hidden) -3DGenerator, 3D inventory, so nothing to studies.
                        How can I have access to thoses ?

                        I am reviewing the use of scaleform and to have proper documentation and examples (the clik Ui etc..) i may be interested by purchasing a license, but i can't tell if I can use a bought license of scaleform WITH UDK (and in particular the Oculus UDK)

                        Could you enlighten me on the subject ?
                        Merci !