Announcement

Collapse
No announcement yet.

render target crash

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    render target crash

    hi,
    i'm trying to setting render target of 3d model to scaleform .i've follow the guide http://udn.epicgames.com/Three/GFxUs...erTargets.html but when flash call external interface and uscript perform SetExternalTexture function,udk crash without any messagge (only "Critical error" ) .


    i've tested solution from this topic http://forums.epicgames.com/threads/...CLIK-UILoader? , but nothing change.


    The rendertotexture2d actor function properly : if it use on a material and apply , for example, to brush i can see the rendered scene.


    all in the november 2011 (with gfxeporter patch applied) udk,with as2 flash .
    someone managed to run the render to texture (after august version)? I looked for known bugs without finding anything


    thx


    #2
    Yeah this has been a big issue for a while now. There have a been a ton of threads about this in the last few months.
    http://forums.epicgames.com/threads/...-UDK-instantly

    In short, if you need to use scaleform, you pretty much have to use UDK-2011-10. There are several projects that im aware of (including my own) that are stuck on UDK-2011-10. Basically scaleform4 (UDK-2011-11 and later) was released before it was actually ready.

    I did get a response from Matt Doyle about this exact issue in the form of a private message. it read, and I quote
    "The team is aware of it."

    Here is to hoping that a fix is released in UDK-2012-02!

    Comment


      #3
      ok
      then waiting for the fix ...
      thanks .

      Comment


        #4
        I am still having this problem. How come 4 versions of UDK comes out with a big bug like this, that were reported several times here on this forum?

        Comment


          #5
          No idea. Its frustrating. Everyone thats using scaleform and requires this basic render texture functionality is still locked into using UDK-2011-10, which is the last release this was known to work.

          Still its very frustrating. I have asked that they update the docs, or at LEAST post a sticky about this major problem so people dont loose so much time on it, but nothing yet. I did get a pm from Matt Doyle not too long ago that said they are aware of the issue. So scaleform is aware but I have no idea if epic is.

          Comment

          Working...
          X