Announcement

Collapse
No announcement yet.

miniMap vanish after Cooking map

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    miniMap vanish after Cooking map

    Hi every body !
    I have used some Scaleform UI in my "Hud" and "Inventory" and load both with unrealScript .
    and my HUD , Load a "Minimap" swf in Itself .

    Problem:
    When I run my game in editor or with UDK.exe ( I make it default map in DefaultEngine.ini ), Everything works !
    But when I try to Cook it,In output, my Minimap doesn't appear ! but other UI ( Inventory & HUD ) work regularly ...

    Any Idea ?
    Thanks in advance =)

    PS: my Minimap and Hud are made according to "Matthew Doyle-11 Part" Tutorial !

    #2
    Hey, I dont have a solution for you, but I thought you might like to know that I am currently having the same problem

    Your not alone!!!

    Comment


      #3
      Add your UI Scaleform package (the package containing your UI) in the DefaultEngine.ini:

      [Engine.PackagesToAlwaysCook]
      +Package=MyScaleformPackage

      Comment


        #4
        Sorry, But It didn't help :|

        Comment


          #5
          Is the minimap and the other UI elements in the same package?

          Comment


            #6
            My packages, are :
            1.myHUD : HUD and Minimap
            2. myInv : Inventory

            I even add "myHUD" in [Engine.PackagesToAlwaysCook], But It didn't help .
            I think, cause my "Minimap.swf" is same as UDK one ( I just used it ), and in this file , There are some reference to some "Class" (e.g: reference to "com.scaleform.Minimap" class ), This may make problem in final output and maybe these Classes, don't cook .
            ":

            Comment


              #7
              I tried this too, and it didn't work unfortunately

              Comment


                #8
                Did you ever manage to figure this out?

                Comment


                  #9
                  Yes, in the content browser, find the HUD swf movie file, and double click it to bring up the properties. Go back to the content browser, find your minimap swf file, and click on it so its highlighted in yellow. Go back to the properties window of the HUD swf, and under user references, add a new line, then click the green arrow to add the file path of your minimap.
                  Hopefully that fixes your problem!

                  Comment


                    #10
                    Originally posted by Elphus View Post
                    Yes, in the content browser, find the HUD swf movie file, and double click it to bring up the properties. Go back to the content browser, find your minimap swf file, and click on it so its highlighted in yellow. Go back to the properties window of the HUD swf, and under user references, add a new line, then click the green arrow to add the file path of your minimap.
                    Hopefully that fixes your problem!
                    thanks very much!

                    Comment

                    Working...
                    X