No announcement yet.

Scaleform UI without Flash: Vectorian Giotto and FlashDevelop

  • Filter
  • Time
  • Show
Clear All
new posts

    I got a question, as I am attempting to create a HUD using Giotto, I wanted to know how you can Convert an Object to a symbol->graphic. In flash it was Right Click -> Convert to Symbol -> Then choose graphic. In Giotto, I can only choose Movie Clip or Button...

    Or could you maybe do a tutorial on how to make a HUD using Giotto? I know that's a big request, but I'm trying to use the SMU Guildhall Tut with Giotto and it's a mess because there's things in Flash which aren't there in Giotto.


      thanks for the info !!!! really good !!!


        Does this even work for anybody? If I could get a mouse cursor to appear in UDK, just that, I would be amazed.

        Update Edit: I got Sothink SWF Quicker and that puppy works! Very happy!



          I have found this thread very useful but I was wondering, would anyone know how to output a fs command when you press one of the buttons in FlashDevelop? Or just how to use a button press as an input for Kismet in unreal?


            I was able to get fscommand working easily with Flashdevelop. Make sure you move the CLIK directory above your src directory in FD. You can set the "Project->Properties... -> Output (tab) -> Test Project " to "Run Custom Command" then click the "Edit..." button and put the following as your Command: "<path to your UDK-<date> dir>\Binaries\GFx\FxMediaPlayer.exe <path to your output swf>". This allows you to run the scaleform viewer right from FD, which makes things easier.


              Excellent thread and tutorial, thank you very much for this. For a first-time game developer with no budget, tutorials like these are life savers !


                Is there a way to share resources between flash files in Giotto like there is in Adobe's Flash? So I don't have to embed every image for every swf and thus eat up my memory ingame? I just briefly looked at Vectorian Giotto and can't find something that would support that. Or can it be done in FlashDevelop? I think this is very important.


                  I'm having trouble with using fscommands in flash develop. Would the code for the button be the same as it is when using adobe flash after going into the actions menu?

                  Would I be able to type:
                  on (press)
                  fscommand("load map");

                  And then hook up the necessary nodes in kismet or is there more code to input into the FD file before I can call the fscommands through kismet?

                  Thanks in advance!

                  Sent from my Galaxy Nexus using Tapatalk


                    Ok, I tried the above referenced code that Donald had mentioned in an earlier post and I'm getting the following error:

                    src/ characters 0-6 : parse error Unexpected import

                    Here is my code:

                    class SnowballMainMenuVG
                    import flash.external.ExternalInterface;

                    static var vectorApp:SnowballMainMenuVG;
                    //serves as entry point
                    static function main(mc:MovieClip):Void
                    vectorApp = new SnowballMainMenuVG();
                    public function SnowballMainMenuVG()
                    var mouseListener:Object = new Object();
                    mouseListener.onMouseMove = function()
                    //Set the cursor instance position to the mouse position
                    _root.cursor._x = _root._xmouse;
                    _root.cursor._y = _root._ymouse;
                    _root.exitBtn.onPress = function()



                    Any suggestions as to why i'm getting this compile error when everything was done exactly as stated in the tutorial?


                      The error is caused by having imports inside your class. Move the import statement to be before the class declaration. My Actionscript 2 is a bit rusty, but at a glance the rest looks like it should work.


                        That worked like a charm as far as getting the script to compile! I'm going to hook up the kismet work to see if it actually works when played in PIE or in game from the command line in visual studios.

                        Would I do something like what I have above to get the play game button to work or would I have to go another route and have it call Unrealscript externally in order to set up fscommands to play with?

                        I'm new to flash development but I'm liking it more and more as I see success when I try different things.

                        Thanks for the reply

                        Sent from my Galaxy Nexus using Tapatalk


                          can we manage CLIK components not using Adobe Flash Professional somehow?
                          does it work with Vectorian Giotto?


                            Sweet tutorial Donald dude, I'm so happy UDK has such a dedicated developer community XD


                              Alright, so I'm using both flash develop and giotto. So far I got a png mouse working and my menu running when I start my test level.

                              My main is issue is that while debugging my button that's supposed to allow me close the menu I noticed how WidgetInitialized is never being called, here is my defaultproperties code where i add the widget

                              WidgetBindings.Add((WidgetName = "TestButton", WidgetClass = class'GFxCLIKWidget'))

                              I was wondering if anyone has found ways around this, I've also tried the externalinterface route through my flashdevelop code to an unfortunate dead end as well.

                              - is there something I can do in flashdevelop or giotto for unrealscript to know that my button is a widget or the fact that I made it a button already mean that it's a widget


                                Is it a button from the CLIK library? You'll have to manually set in your actionscript the callback flag:
                                MyWidget.enableInitCallback = true