Announcement

Collapse
No announcement yet.

Disappearing Swf Files from UDK

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Disappearing Swf Files from UDK

    Hello,

    I've been following some of the guides listed here to create a main menu in a project I'm working on. For the time being, I was using the CLIK_tutorial_skinned example with an added mouse layer until I created my own menu. This worked fine, until I started making changes. I renamed the file and saved it in its own file (Flash/Spelunk/SpelunkMainMenu.swf).

    It imported fine into UDK, and everything worked right by putting it into the Movie field under Open GFx Movie in Kismet, like the video tutorials explained. The project saved fine, and even ran correctly when I went back into Visual Studio and compiled the code.

    However, if I make one code change and re-compile the files, the menu disappears. It just loads the basic map and nothing else. So I went back to UDK and when I load the map, I get a warning that it can't find the SWF attached to the map anymore. The Movie field on Kismet is empty. Now I noticed that when I re-import my swf, it's not actually placed into any package on the content browser. It can find it if I click the "Find object in Content Browser" button in kismet, but I can't find it through any search in the content browser.

    I'm relatively new to Scaleform, so if I'm missing a key step to importing the swf files, any help would be appreciated. Thanks!

    #2
    Hi there, when you imported into UDK, did you save your file? If not I suggest you restart yur UDK because sometimes this happen to me too
    You have to make sure that the package must be save inside the correct folder and reimport it.

    Comment


      #3
      This doesn't sound like a Scaleform issue. It sounds more like a general UDK usage issue. My advice is to start clean, and save the SWF in the appropriate place from the beginning before importing into UDK.

      Comment


        #4
        I have recently also come across a missing or non working flash file.
        Without releasing too much information, basically I'm working on a game in development and all of the menus in game worked fine.
        We upgraded to the most recent UDK from the jun 2012 version(or close to) and now everything works apart from one menu.
        The work flow is the same the settings are the same and everything inside flash, all menus are fine apart from one now(was working perfectly).

        The only thing i can see is the log and it states this :
        [0025.03] ScriptLog: **********:: TargetView is null. Unable to push view onto stack.
        [0025.03] ScriptWarning: Accessed None 'SettingsMenu'
        **********

        Any ideas weather this warning is a code issue, or flash issue?

        UDK seems to re-import and save the files just fine. all assets and swf's go in perfectly just as the other UI elements do.
        But for some reason this one is giving me some hassle.

        Comment

        Working...
        X