Announcement

Collapse
No announcement yet.

Blank menu?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Blank menu?

    I have no idea what have changed but i am experimenting with the UDKfrontend and everytime i do a test or publish and reimport to udk all menus are gone and it only shows the background.

    I then add the old frontend.upk back and it is working.

    I do not even have to change anything, all it takes is a publish and reimport.

    Any ideas?

    #2
    With blank menu i mean that it do not load any movies what so ever except for the manager.

    Comment


      #3
      Could be many reasons. You might be reimporting the wrong file from the wrong location. You might have compile errors in Flash that you need to look at, possible missing class paths.

      Comment


        #4
        I am guessing that i got the com/scaleform/... in the wrong location.
        I had gfxfontlib and com folder warnings, moved them to same folder as swf and then no warnings. Still no go.
        Was hoping to use the udk front end files for test and learn but it just got me more confused lol

        All i have to do to get it to fail is to open the manager main menu fla. press test, import and it fails.
        Keeping the exact same structure as when installed.
        I am importing the udk_manager.

        Comment


          #5
          Do NOT move the com folder. You need to follow the setup procedures outlined in UDN:

          http://udn.epicgames.com/Three/Scale...%20Environment

          See the heading - Setting Up CLIK Class Paths

          Comment


            #6
            Here's an error message I am getting even after doing the guides from Matt.

            Error: GFxLoader failed to open 'D:/UDK/UDK-2010-11/UDKGame/Flash/UDKFrontEnd/ud
            k_assets.swf'
            GFxLoader failed to open "D:/UDK/UDK-2010-11/UDKGame/Flash/UDKFrontEnd/udk_asset
            s.swf"
            Error: Failed to create a movie from 'D:/UDK/UDK-2010-11/UDKGame/Flash/UDKFrontE
            nd/udk_main_menu.swf'

            Comment


              #7
              You need to run each movie once to create the actual swf.

              Comment


                #8
                I added fourcourseui components think thats what broke it, i just remembered i had it in there.
                Reinstalling for the tenth time

                Comment


                  #9
                  i give up using the supplied udkfrontend and keep using my own.
                  Complete reinstall.
                  Change nothing except publishing new files = blank menu with nothing but a background from udk_manager.

                  Everything is set up according to manuals.
                  Error while "test with FXmediaplayer" = CallMethod - 'SetDocumentClass' on invalid object.
                  Meanwhile i changed nothing. Perfectly clean install.

                  Comment


                    #10
                    If I'm going to be able to help you, I'll need to know the exact steps you are taking.

                    Something to try:

                    Add: C:\UDK\UDK-2010-11\UDKGame\Flash\ActionScript to your classpaths.
                    Publish C:\UDK\UDK-2010-11\UDKGame\Flash\UDKFonts\fonts_en.fla
                    Publish C:\UDK\UDK-2010-11\UDKGame\Flash\UDKFonts\gfxfontlib.fla
                    Publish C:\UDK\UDK-2010-11\UDKGame\Flash\UDKFrontEnd\udk_assets.fla

                    Then publish C:\UDK\UDK-2010-11\UDKGame\Flash\UDKFrontEnd\udk_main_menu.fla

                    You should see the menu.

                    Comment


                      #11
                      Exact step: Test with original udkfrontend.upk = all good.
                      Add paths as told at http://udn.epicgames.com/Three/Scale...%20Environment
                      Open udk_main_menu.fla
                      Press 'test with GFxMediaPlayer'
                      ReImport udk_main_menu to udkfrontend
                      save
                      fail

                      Open udk_main_menu.fla
                      Publish udk_main_menu
                      ReImport udk_main_menu to udkfrontend
                      save
                      fail


                      fail = blood1 and blood2 background and floating particles, nothing else.

                      Comment


                        #12
                        Part of your problem is thinking that all you have to do is publish udk_main_menu and reimport.

                        That file is dependent upon several other files. See my previous post for steps to help you.

                        Comment


                          #13
                          Same result after exporting every fla i can find in the install.
                          I will test with november install on another computer

                          Comment


                            #14
                            Hmm. I can confirm it works on my end. I did this:
                            1. Add: C:\UDK\UDK-2010-11\UDKGame\Flash\ActionScript to your classpaths.

                              NOTE: this is in addition to the normal classpaths you must add from the UDN instructions. I put it above the normal CLIK classpath.

                            2. Publish C:\UDK\UDK-2010-11\UDKGame\Flash\UDKFonts\fonts_en.fla
                            3. Publish C:\UDK\UDK-2010-11\UDKGame\Flash\UDKFonts\gfxfontlib.fla
                            4. Publish C:\UDK\UDK-2010-11\UDKGame\Flash\UDKFrontEnd\udk_assets.fla
                            5. Add a yellow square to the stage of udk_main_menu.fla.
                            6. Publish C:\UDK\UDK-2010-11\UDKGame\Flash\UDKFrontEnd\udk_main_menu.fla
                            7. Reimport udk_main_menu in content browser.
                            8. Save
                            9. Launch game - menu works as expected and has big yellow square in it.

                            Comment


                              #15
                              i am sure i messed something up somewhere, thereby why i will try it tonight on a fresh computer.

                              I really can not get it to work no matter what i do.

                              Comment

                              Working...
                              X