Announcement

Collapse
No announcement yet.

frustrating problem getting CLIK classes to load, plshelp

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    frustrating problem getting CLIK classes to load, plshelp

    Hello all, we're getting a few people on our team set up to work on scaleform, all using CS3

    myself, ive had no problems following the installation and am happily building stuff, including CLIK components, and getting it working inside UDK.

    however another on our team is having a problem where CLIK classes are failing to load, the specific error being "GetVariable Failed: Cant resolve the path 'gfx.controls.TextInput'

    we have checked our setups against his extensively and pored over the installation documentation, but -

    - he has installed the workflow enhancement extension correctly
    - he has set up the CLIK classes in the flash prefs/actionscript 2.0 setting dialog correctly
    - his udk installation is normal, with all the /development/flash files present
    - the movie we're testing on works on 2 other people's systems without alteration

    the only difference i can see in his setup is that he runs udk from his F: drive (however all the disk location settings detailed above are correct for this)

    [SHOT]http://dl.dropbox.com/u/791295/failmessage.png[/SHOT]
    [SHOT]http://dl.dropbox.com/u/791295/CLIKcomponent.png[/SHOT]
    [SHOT]http://dl.dropbox.com/u/791295/as2settings.png[/SHOT]
    see? proofs!

    yet we cannot get the CLIK components to run on his system.

    can anybody help here?

    #2
    shameless BUMP!

    Comment


      #3
      The runtime errors (in FxMediaPlayer) could be caused by a broken SWF. In the third screenshot I am seeing many compiler errors in the Flash IDE. Are you running the SWF that was generated with compiler errors?

      Comment


        #4
        no, as far as i know this swf does not generate compiler errors on the systems where it works ok,

        Comment


          #5
          chekc your path to the flash directory, make sure its complete - looks like flash isnt finding the custom .as files here.

          sometimes i have had to remove the udk dir and re-add it to get it to work.

          Comment


            #6
            CLIK and GFx are confirmed working with CS3, so I'm not really sure what's wrong here. The classpaths appear to be setup correctly. But I'd say try it again, and make sure its pointing to the right place. Don't copy and paste it in, but browse to it using the browse button.

            If everything is working fine on other machines with similar setups, it really sounds like something he is doing/not doing correctly.

            I just put a UDK install on my H drive (to test whether non-C drive installs are ok), set the class paths to the UDK on that drive in Flash (H:\UDK-2010-10\Development\Flash\CLIK), imported a new/unmodified TextInput CLIK component into a new AS 2.0 doc from that location, and published it to the Oct 2010 UDK GFx Player, and it worked fine, no errors.

            Comment


              #7
              thanks for your help guys but we still havent isolated this. we're getting our poor unfortunate to do a complete reinstall of our entire dev build, see if that catches it.

              Comment


                #8
                Sorry to hear that. Wish there was something I could do. Its a strange issue, and I'm not sure why it works on other machines, but not his.

                Comment

                Working...
                X