Announcement

Collapse
No announcement yet.

fscommand should not be used for production......error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Hey there guys,

    I was wondering, is there a way to do this same thing, but only in kismet rather than going into code?

    I'm trying to achieve a change being activated in scaleform via kismet.
    For example, if a player completes a level, I would like a colour change to be displayed on their map, but, but their map is entirely scaleform and kismet based, no scripts involved.

    Thanks

    Comment


      #17
      I'm actually wondering why. Why shouldn't fscommand used for production? What would happen if it's used for production?

      Comment


        #18
        Matt, I tried the fscommand substitute scripts you mentioned above and it works (what else?)
        In Flash I am having 10 buttons in a switch case and each has
        ExternalInterface.call("MyUnrealScriptFunction",1) ;
        ExternalInterface.call("MyUnrealScriptFunction",2) ; etc...
        Now in Kismet I place the RemoteEvent and name it MyEvent .... but how do I pass the second parameter (1,2,etc)
        Thanks

        Comment


          #19
          Originally posted by taz1004 View Post
          I'm actually wondering why. Why shouldn't fscommand used for production? What would happen if it's used for production?
          i tried using it in production and my neighbours cat exploded!
          no not really
          does seem strange that fscommand exists (and works fine) but gives an error (that isnt really a propper error).

          any clues?
          or nobody knows why?

          Comment


            #20
            Matt again:
            I didn't get an answer from my last request above so I tried an approach that WORKS but seems to me too long:
            code in MyGFxMoviePlayer.uc:

            //function to receive External Interface call
            function MyUnrealScriptFunction(int n)
            {

            switch(n)
            {
            case 0:
            TriggerRemoteKismetEvent('MyEvent0');
            break;
            case 1:
            TriggerRemoteKismetEvent('MyEvent1');
            break;
            case 2:
            TriggerRemoteKismetEvent('MyEvent2');
            break;
            ........ etc for all numbers
            It's a pity that the RemoteEvent in Kismet cannot take any parameters otherwise it would be easy and much shorter.
            Comments?

            Comment


              #21
              Sorry. I was out of the office yesterday. Yes, Remote event does not take parameters. You'll have to figure something else out if you want to send parameters. Some things you could do:

              A. Create your own kismet remote event sequence that DOES accept parameters - this is beyond the scope of Scaleform UI though.
              B. Store the parameters in variables in Flash/AS, then get those variables with the Kismet node: GFx GetVariable. Using that, you put the fully qualified path to the variable in Flash/AS in the Variable field, and then you connect the Result to whatever variable type it is (string, int, bool, etc.).

              Comment


                #22
                It also seems possible to use "GFX get variable" to replace fscommands entirely.

                By creating a loop that periodically checks the value of a variable in flash, kismet can respond to an event in flash which changes that variable.

                Combined with a switch statement it can then respond to multiple events.

                For use when the "fscommands are only for prototyping" errors are bugging you and you don't want to write any unreal script.

                Just make sure that the flash movie is still loaded when you check the variable, otherwise UDK completely crashes.

                Comment


                  #23
                  Matt if you could please help shed some light on why i cant get the external interface to call my function in uscript id be so grateful.when i use the scaleform launcher in flash i see it log callback myunrealscriptfunction but in my GFxMoviePlayer class in udk it never calls the myunrealscriptfunction! everything else works perfect i just cant for the life of me get it to fire my function. thanks in advance

                  Comment

                  Working...
                  X