No announcement yet.

fscommand should not be used for production......error

  • Filter
  • Time
  • Show
Clear All
new posts

    fscommand should not be used for production......error

    I just have one fscommand in my map that closes the my swf in the 'open GFx movie' command. When I open my load the map it comes out with the above error plus this "....This is for prototyping only FxEvent_FsCommand .... (name of my map)

    what am I doing wrong?

    here you are, i asked the same thing


      Thank you but the remedy is Chinese to me. Where do I insert the code that EUROSAT7 mentions? and what is the answer from Doyle: "External Interface" means ????


        From Flash:

        import flash.external.ExternalInterface;
        // ..."MyUnrealScriptFunction", param1, param2, param3);
        The above code would then look for a function called "MyUnrealScriptFunction" in the current GFxMoviePlayer instance in Unreal, convert the parameters to the parameters of that function in UnrealScript, and call the function. Note that the UnrealScript function's parameter list is authoritative in this case, so if the parameters passed from ActionScript cannot be cast to the UnrealScript function's parameter types, they will be NULL or their default value, as appropriate.


          I still don't understad. I have a simple Flash button with some text, I right click the Button and call Action, there I write this:

          on (press) {

          In Kismet I open the GFx Movie and so on and separately I place a fscommand with "start" as the fscommand. The output just does a CloseGFx Movie command
          And IT WORKS OK but when I open the map it says always:

          My_scaleform_test GFxEvent_FSCommand_0 FS Commands should not be used for production. This is for prototyping only GFxEvent_FSCommand
          Please Matt Doyle what is the right procedure? where do I install the code you mention above?
          I appreciate it


            So, your Flash button would instead have his:

            ActionScript 2.0 Method

            on (press) 
                import flash.external.ExternalInterface;
            You can pass as many or as few parameters as you like with an ExternalInterface call (example:"MyFunction", "Matthew", 37, true) passes a string value, an integer, and a boolean). In this case, we aren't passing any. We're just calling the function MyUnrealScriptFunction.

            And in your UnrealScript, you would have this:

            class MyMoviePlayer extends GFxMoviePlayer;
            //function to receive External Interface call
            function MyUnrealScriptFunction()
                `log("###### ExternalInterface Call Received #####");
            //function to trigger a remote kismet event
            function TriggerRemoteKismetEvent( name EventName )
                local array<SequenceObject> AllSeqEvents;
                local Sequence GameSeq;
                local int i;
                GameSeq = GetPC().WorldInfo.GetGameSequence();
                if (GameSeq != None)
                    // find any Level Reset events that exist
                    GameSeq.FindSeqObjectsByClass(class'SeqEvent_RemoteEvent', true, AllSeqEvents);
                    // activate them
                    for (i = 0; i < AllSeqEvents.Length; i++)
            	    if(SeqEvent_RemoteEvent(AllSeqEvents[i]).EventName == EventName)
            	    SeqEvent_RemoteEvent(AllSeqEvents[i]).CheckActivate(GetPC().WorldInfo, None);
            Add a Remote Event Kismet node in the level, and give it a name of MyEvent.

            Then link that event to whatever you desire to occur.


              Thank you I'll try. But one question remains: where do I write the code in UnrealScript? which file? in which folder of UDK?, is it a new file.uc that I must create or do I write it inside one of the many .uc files?
              Not having written any code in UnrealScript (just copying verbose what I read from examples) you may understand my predicament here.


                Sounds like you need to start from the beginning. Everything you need to know has already been written in documentation or put into tutorial videos. Please review the Getting Started with GFx sticky forum post - there are tons of links to tutorials there.


                  Yes sure !!, I have tried to do that with all of your Video tutorials. The last one "Getting started with CLIK Video tutorial 1 (9 steps) and it is almost impossible to follow BECAUSE OF UDK AND FLASH AND PHOTOSHOP constantly coming out with new versions.
                  By following the first 2 Steps of the above tutorial when I run it with Test with FxMediaPlayer in comes out with the following error list
                  , Line 1 There is no class or package with the name 'gfx.controls' found in package 'gfx'.
                  , Line 1 There is no class or package with the name 'gfx.controls' found in package 'gfx'.
                  , Line 1 There is no class or package with the name 'gfx.controls' found in package 'gfx'.
                  , Line 1 There is no class or package with the name 'gfx.controls' found in package 'gfx'.
                  H:\UDK\UDK-2010-10\Development\Flash\CLIK\gfx\controls\, Line 442 Type mismatch in assignment statement: found Number where Boolean is required.
                  H:\UDK\UDK-2010-10\Development\Flash\CLIK\gfx\controls\, Line 318 There is no property with the name 'bindingEnabled'.
                  H:\UDK\UDK-2010-10\Development\Flash\CLIK\gfx\controls\, Line 313 There is no property with the name 'bindingEnabled'

                  plus the DOS window created shows this:
                  "jpeg system is not installed.... Load _level10.optionsBtn
                  It is discouraging. Thanks for your time anyway.


                    I advise you to ignore the CLIK videos for now, and focus on reading the UDN Scaleform web pages, and watching the UDK specific video tutorials. They cover most if not all of what you are asking help with.

                    For instance, if you read the UDN docs, you will see that jpeg is not to be used. You must set all images to PNG/lossless compression in Flash. And the docs, as well as the first UDK video explains how to do that.

                    Also, you said:

                    where do I write the code in UnrealScript? which file? in which folder of UDK?
                    These questions are answered in the UDK video on creating a custom menu.

                    So, rather than repeat myself on the forums, I recommend those docs and tutorials. Study them thoroughly and you will be well on your way to understanding how it all works. But, if you don't know how to write code, and don't understand UnrealScript, you're going to need to learn that as well.


                      It is true that there are many revisions from month to month as UDK changes, etc. And, sadly, I can't keep up with new video tutorials very often, especially considering UDK tutorials are not my only responsibilities here at Scaleform. But I'm confident you should still be able to get some good value out of the ones available now - most of which were put together on August & September UDK, using Flash CS4.

                      A few months down the road, I'm sure we'll revise these tutorials to bring them up to date, and probably continue to revise them every few months or so (if needed).


                        Mr. Doyle, please just let me know where do I place the code in Unreal script that you mention to remedy the fscommand error mentioned above. I can enter code but in which .uc file and which folder? or do I have to create another uc file and then compile.
                        I appreciate it because everytime I use this fscommand it shows the error and it becomes irritating


                          Matt Doyle: would you please tell me into which file and which folder do I introduce the Unreal script code you mentioned above? or is it a new file to make?
                          I have changed .uc files within UDk (to include a new character in my games) so I would know how to do it I only need where?
                          Thank you


                            you need to make a new file and put it in your script package, if you dont have your own yet do a getting started in udk or a simple game tutorial or something.

                            one question remains though matt doyle please
                            why is fscommand not reccomended?
                            will it break or what?


                              You have to create a new class file. This class file should live in the UDKGame classes folder under Development/Src. Call the class whatever you want. Put the code in there. The class must extend GFxMoviePlayer.

                              In Kismet, when you use OpenGFxMovie, in the dropdown where you choose GFxMoviePlayer, change it to your new class file.

                              If you watch video tutorial 6 (creating custom menus) it tells you all the details of this (creating a new class, and setting up Kismet, etc.)