No announcement yet.

Inventory Demo

  • Filter
  • Time
  • Show
Clear All
new posts

    Oh - no that has no effect on compile.


      This is maybe a stupid question, but how do you debug your unrealscriptclasses of gfx ?
      I tried to use log and ClientMessage but they give errors.

      Edit: looks like 'log works.

      Edit2: I want to let my hud be floating above a pawn in third person. is the best way to make a material with the swf and assign it to a plane that I link to the pawn or is there a better method?


        I am a bit stuck on this so srry for the double post.

        Like you suggested I looked at those classes and I have now written my own class. But I couldnt get the effect what I wanted. Like you can see here.

        The problem here is that the UI is always in front of the playercamera while I want that the UI will be above a charackter in front of me. Floating above his head. The good thing is that here the UI gets the mouseinput. So that works well.

        I wanted to solve the problem of the UI that has to float above a player. So I tried to assign a material with a rendertotexture2d to a plane. Like you can see here the UI is visible but the colors are gone and there is no mouseinput.

        I already edited in kismet the property "Take Focus" and "Capture Input" of the Open GFx Movie node. But nothing happens.

        Could you help me a bit pleas ?


          Nobody has an idea? I saw that there was a focus node in the previous version of udk. Why is this gone and what do you have to do now?

          I hope somebody can help me.


            I'm not familiar with how to do this, otherwise I'd offer some pointers. I do believe that capture input and take focus seem kind of broken in September UDK in Kismet. If you have capture input set to true, that movie will capture input no matter where you are in the level.

            I believe the way we did 3D inventory window in the previous builds (window rendered behind player gun) was with some modifications that no longer exist in the new builds. So in order to find out how we did it, I'll need to dig around in an older version. Unfortunately, I don't have the time to do that right now.

            I do know you can capture mouse input from UnrealScript as well. Some default properties to consider when doing something like this include:

                bIgnoreMouseInput=FALSE // this determines whether the mouse is captured or not
                bPauseGameWhileActive=TRUE // do you want your game paused when this is open?
                bDisplayWithHudOff = TRUE // do you want the HUD displayed while this is open?


              Ok thank you for your help Matt Doyle.


                is there a way I can disable an inventoryslot ? I tried the property _enabled, but this didn't worked. I can still drag and drop from it.

                EDIT: nvm, without the _ it worked!


                  its going to sound stupid, but where is the inventory demo located? Is it for scaleform licensees only?


                    Do some digging in the /Development/Flash folder. You'll find it.


                      Thanks Matt. Sorry for the insane delay.

                      I was using flash CS3 and kept getting "unexpected file format" when trying to open up some of those resources. I just upgraded to flash 8 pro, but the same thing is still happening. Does this sound like a compatibility issue or am i missing something?


                        Probably because those files are CS4 files.


                          whoops. Alright thanks i'll try to switch to the right version.


                            How would one go about equipping an item in-game, such as armor, when the icon has been dragged to the slot(armor dragged to armor slot). I have looked the InventoryDemo over and over and can't make out a function that can allow me to do this.

                            I believe that this code is responsible for making this occur,

                            dragBtn.onPress = function() {
                            	// not sure why onMouseUp doesn't work here.
                            	this.onRelease = this.onReleaseOutside = function() {
                            but how can I apply this code so that when armor is in the armor slot, it performs an action that equips armor.
                            Also, how can this code be referenced by UnrealScript?


                              Still trying to figure out how to actually equip an item in-game when a button has been populated with an item. Any hints?


                                for this stuff to translate to in-game actions you gotta make actionscript communicate with unrealscript (see Matt Doyle's tutorials), and write your own functions so that actionscript is able to call the apropriate unrealscript function for the equipping/unequipping to happen