Announcement

Collapse
No announcement yet.

Scaleform Fonts

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    I disabled my script. I tried typing a default value in the field in flash "00:00". It showed up. I changed the font to italic. Still showed up right (in italic). Enabled the script again. Empty squares. Changed to regular. Showed up right again (non-italic of course).

    Then I changed the script to always update the field with the string "hello 123" every frame. Same results. Worked for regular but not italic.

    I was pretty **** sure it was me missing some detail here (it can of course still be me screwing up, I cannot be 100%). But yeah, this looks indeed very strange. If it could be looked into or recreated it would be pretty cool.

    Thanks for your time, Matt. Very appreciated.

    EDIT: Okay, I saw your last post now. I'll test it right away!

    Comment


      #17
      Hm, I'm pretty new to Flash, so I'm not sure if this is right? Is this the button you mean I should "unclick" when you say that I should disable html in the tetfield?

      <> Render text as HTML

      If so, I'm afraid it has been disabled from the very start.

      EDIT: And enabling it didn't help either.

      Comment


        #18
        Now that is very strange indeed. I've tested it on my end and that was the problem (html text).

        Ok - try this:

        Ensure you text field is:
        • Dynamic Text
        • Family: Georgia
        • Style: Bold Italic
        • Not using Auto kern
        • Anti-alias for readability
        • Not selectable
        • Not Readable text as HTML
        • With Basic Latin glyphs embedded


        Publish & reimport. Then test in UDK.

        Comment


          #19
          From my testing, it looks like these two font settings cause problems:

          Auto kern
          Render text as HTML

          Be sure to disable these two options on any text fields you want to set dynamically from UnrealScript that make use of Bold or Italic styles.

          Comment


            #20
            Auto Kern! That was it. (actually didn't even know what it was until now). Thanks so much for your patience Matt. Now I can leave for christmas with that nice feeling of success. And last bus home from the office goes in like 15 minutes, so pretty nice timing. =)

            I tried html thingy too. Same thing, so you were right there. We can not leave html or kerning on if we want to update the field from the script.

            Thanks again. You're the man, Matt.

            EDIT: Hehe, we wrote at the same time.

            Comment


              #21
              I had a similar issue. I was able to address it by checking out the [Fonts] section on in the UDKGame\Localization\INT\GFxUI.int file. It needs to have the font name and the font it's mapped to identical to what you use in your fla.

              Ex.
              [Fonts]
              NormalFont=Bitstream Vera Sans
              BoldFont=Bitstream Vera Sans,Bold
              StencilFont=Bobs Stencil
              TitleFont=Bobs Title

              Comment


                #22
                Originally posted by Matt Doyle View Post
                • With Basic Latin glyphs embedded
                How do I enable Basic Latin glyphs embedded? I am using Adobe Flash Professional CS5.5 and NOT CS4 like you use for demonstration in your video tutorial.

                Thanks for your help.

                Comment

                Working...
                X