No announcement yet.

UDK mesh error problem

  • Filter
  • Time
  • Show
Clear All
new posts

    UDK mesh error problem

    Hi, this is my first post on this forum so apologies if this is in the wrong area or has been covered somewhere else. I have looked extensively for a solution online but can't find anything. Any help with the following is greatly appreciated.

    Basically I'm having this issue with this potion model in which some of the faces appear flipped in the engine. It's definitely an issue with the mesh as I have other potion models that work that use the same material, and the texture is also fine.

    Things I have tried to fix it are make sure all faces are faced in the right direction in max, unifying the normals, no flipped uvw faces and it has a lightmap channel with no overlapped faces.

    One thing that does seem to effect it is smoothing groups although I can't seem to control its effect. I have tried autosmooth various angles and assigning groups manually how I thought they should be smoothed but the results seem random. The triangulation on the mesh is also unified and flowing in the same direction but this could also have something to do with the result.

    Any ideas on this please let me know.

    Also I'm not sure how to upload the file so if you want to take a look at the max file let me know how to upload it and I will gladly do so.

    Thanks very much.

    Edit: I'm using the latest udk build february 2015 and 3ds max 2014. I had the same issue on the previous udk build though.

    You're getting an R shape on your mesh. You checked for flipped normals, overlapping, then maybe it's just an anomaly and I get those occasionally - a face twisted inexplicably, an edge won't show, a vert goes weird. I delete the offending edge, face verts and remake the area. Ultimately your mesh look pretty simple, delete it and remake? Making a mesh like that I'd start with a circle and extrude upwards (or start from the top, whatever), and extrude at each curve giving me the vase shape until reached the top. Maybe you've messed around with the R area?

    I've never had any issues with smoothing - using an olde Blender it's smooth or flat- too easy. But Maya's smoothing is freaky - tho I haven't learned about Maya's smoothing yet, and it's probably similar to Max'. Must be a lot of info online about smoothing though.


      Hi Snipe, thanks for helping me out with this. So I made it from scratch again as you suggested starting from a circle and extruding upwards (I used a line and lathed it originally) and got pretty similar results:

      No flipped normals, faces all facing the same way. I also softened the r shaped section to see if that would help with no luck. Any more suggestions? This is killing me lol. I do appreciate the help tho.



        I don't know if this video demonstrates the issue better. I am adamant that all the faces are faced in the right direction.


          Now you have a jagged triangle. Stating the obvious first - is the liquid poking through the bottle? Try scaling the liquid down, or the bottle up?

          Do you really need a separate liquid? Maybe you need it separate because the liquid is reduced in your code when drunk or poured...? If not, make a liquid top surface inside the bottle. Texture the liquid area from the narrow base to the top surface. You could easily do that with one texture because liquid and bottle are both transparent.
          Or not, glass very obviously around the outside is probably what you want. I can only think it's your scaling - certainly from the video, its seems like the scaling - the liquid actually looks bigger than the bottle. Bringing the bottle into UDK it will probably be rotated so you see it from the other side and then the R...?

          Sorry that's all I can think of.


            The liquid doesn't come through the bottle at all, unfortunately no matter how much closer to the glass edge or even how much smaller I make the liquid inside seems to have any effect on it. The video is a screen capture from udk. For some reason some of the glass appears in front of the inside liquid even though the bottle is clearly behind in the demonstration. I have a potion that works that's a different shape so I can't work out why this one doesn't. Here's the one that's fine and it also has 'R' shaped parts to it:


              Still no solution to this. Absolutely baffled


                sry... I guess do something else and come back it and a solution will be more obvious


                  Thanks snipe, appreciate your efforts though. Hopefully it will be something painstakingly simple.