Announcement

Collapse
No announcement yet.

Importing UV Map to create Material resulting in bizarre colours & look

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Importing UV Map to create Material resulting in bizarre colours & look

    Hello everyone!

    I'm pretty new to UDK and modelling etc so I may a bit slow, so . . . sorry about that ^^. Now my problem, I've made a wooden texture for a bookcase I've made in 3DS Max, I apply the the texture in 3DS max, it looks quite nice and I was happy. Then I import it into to UDK and everything goes wrong, so from that I'm assuming I'm importing it incorrectly or missing a setting or two. What happens is that it goes all stripey like a 1990's computer and the top goes all yellow. I've added a few print screens to show you what I mean.

    The Texture:



    3DS Max



    UDK


    #2
    My guess is something is wrong with your material in 3ds Max. Make sure your texture map is the correct format, and that it is a resolution that's a power of two. Also make sure your material is a standard material and that it's using a regular bitmap as the map type.

    Comment


      #3
      Originally posted by darthviper107 View Post
      My guess is something is wrong with your material in 3ds Max. Make sure your texture map is the correct format, and that it is a resolution that's a power of two. Also make sure your material is a standard material and that it's using a regular bitmap as the map type.
      Hey bud, thanks for the response. I'm making the material in Photoshop and it works fine in both 3DS Max and Photoshop and when I create just a simple brown, just a "filled-in" brown it still doesn't work in UDK but does in 3DS and PS. The resolution is 1024x1024 and it's a PNG. And as for the "regular bitmap as the map type" I'm not quite getting what you mean.

      Comment


        #4
        Textures are used as a Bitmap map type in 3ds Max, that would be compared to things like Noise, Mix, Mask, etc. If it's not a Standard material or a bitmap texture then it's not going to export correctly.
        Also make sure that it's being imported with the default compression in UDK, maybe it's confused about what the texture is and it's getting compressed wrong.

        Comment


          #5
          Hello, Thanks again. I'm not ticking any of the boxes when I'm importing unless I'm going to make a material and I've stopped doing that so there's less room for error. And apologies but I'm still not quite following what I could be doing wrong to not make it a standard material, I'm literally making it in photoshop, saving as an .png and importing into 3DS Max, works perfectly. Sorry if I'm missing something.

          EDIT: I've also tried using the .psd format and importing it into UDK as the UV Map and it still doesn't like it.

          Comment


            #6
            UDK won't import psd

            What you can try doing is importing the texture separately, and see if it imports correctly. It may be a problem with it trying to import the texture based off the FBX file, you can also try turning on Embed Media in the FBX export settings, that means it will include the texture maps in the FBX file itself rather than pointing back to where the texture is located.

            Comment


              #7
              It did import the .psd but again looked horrible. My models are ASE and not FBX also. But I am important the texture on it's own and that miscoloured THING! :P. I go onto my package and "Import" click "texture.png" and then press "Ok" and that's the result, so I'm fairly sure it's going wrong on the import either it doesn't like the UV Map being a PNG or I'm messing up the settings somewhere.

              Comment


                #8
                Textures are not UV maps, UV mapping is how the texture is mapped to the 3D model.
                Anyways, try saving as a 24-bit Targa file and see if that changes anything. Also, try using FBX instead of ASE

                Comment


                  #9
                  My lecturer has said for me to use ASE, so I dont think I have much of a choice on that and importing textures made in ps is fine and work perfectly like wallpapers I've made without a UV map. However my uv maps are the only ones coming up as the weird colour.

                  Comment


                    #10
                    Originally posted by darthviper107 View Post
                    Textures are not UV maps, UV mapping is how the texture is mapped to the 3D model.
                    this ^^

                    yes psd works with udk
                    are you changing any of the settings on the import dialog?

                    Comment


                      #11
                      Make sure that your textures are 8 bits/Channel (24 bit total, as darthviper said). You can change the bit depth in PS under Image>Mode

                      Comment


                        #12
                        Originally posted by Teyas View Post
                        My lecturer has said for me to use ASE, so I dont think I have much of a choice on that and importing textures made in ps is fine and work perfectly like wallpapers I've made without a UV map. However my uv maps are the only ones coming up as the weird colour.
                        No one is using ASE anymore, it's much better to use FBX especially since ASE support is dropped in newer engines.

                        Comment


                          #13
                          UV & texture Issue related
                          -SOLVED - Thanks "darthviper107" for the Hint: Collapse the UV Channel
                           
                          Spoiler

                          - forgive posting here but no-one replies to my threads, so i ask where people are active and where situations are relevant. also there is way TOO MANY posts on uv's etc and none of them help me, i need a uv/ texture wizard to point out what im doign wrong

                          Comment


                            #14
                            You can do UV mapping a couple different ways, to get things perfect use the Unwrap UVW modifier, from there you can do things like box mapping or planar mapping and then edit the positioning of the faces. Once you've got that done you can collapse the modifier and it will keep the UV mapping. To create your lightmap UV's, apply another Unwrap UVW modifier, but for this one under the Channel section you need to change the channel from 1 to 2. It will ask you if you want to move the UV's to the new channel or abandon the UV's. Move will copy your current UV mapping to the second channel, Abandon will simply move to the new channel but it will not have any mapping on that channel. After that, just create your lightmap UV's and then collapse the modifier. At that point, your mesh will have two UV channels.

                            Comment


                              #15
                              Thanks "DarthViper107"; hopefully this will help both the OP and myself.
                              " It will ask you if you want to move the UV's to the new channel or abandon the UV's. "
                              - From this ^^ i can only assume your talking about 3DSMax 2015, or at least anything after 2010, im more familiar with 2010, i will try 2015 tonight.
                              * i appreciate the explanation and will try it, but do you recommend i click abandon ?
                              - just to clarify... abandon will give you an Empty UV channel 2, but will retain the UVW map in channel 1 - correct?

                              @Teyas :
                              - Try this test Mesh fix.
                              * Ensure that turbo smooth and other unwanted smoothing effects are on this particular mesh.
                              -OR - Take you Mesh - Remove one Face.
                              - Create a vert connection for the 4 verts you need to connect [rebuild the face], check smoothing groups; you should only have 1 total for this hard object
                              ^^ if you do this and simply save & Export - there will be a real difference between the new face and the other faces
                              - Destroy your UV and create a new one, follow darth vipers advice

                              Comment

                              Working...
                              X