Announcement

Collapse
No announcement yet.

I do not know what to call this problem "Normal" problem, I think.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    I do not know what to call this problem "Normal" problem, I think.

    Well, I have been modeling and such and then I tried to re-import my character into UDK, everything has been fine but suddenly the mesh came out weird.
    I don't know why. All I did was exporting the model again from 3ds max to UDK as usual.
    So I looked into it and toggled the Show Tangent to Vector (Show Normal to Vector does the same) and it shows this:

    As you can see, the version that is good is the one of the left side and the bad one is on the right side.
    Now, I don't know what the problem is. I went to 3ds Max and toggled the "Show Normals" on in the Editable Mesh mode and it seemed fine, and the weird edges doesn't show up in the Max renders or viewport.

    My export settings are:

    -Smoothing Groups
    -Tangents and Binormals
    -Triangulate
    -Preserve edge orientation

    Everything else is unchecked as far concerned for the "Geometry".

    I did try fiddling around with the settings, unchecking Tangents or Triangulate and such, but it still gives me that weird result.

    If anyone could be as kind to explain to me what that is and how to get rid of it or fix it, I would be very grateful!

    Thank you very much.

    #2
    What version of udk do you have and max? Are you saving it as the latest fbx file format.

    Comment


      #3
      Hello Ethik, thank you very much for your reply.
      I have the latest version of Max and UDK. And I have tried exporting the FBX as 2014, 2013 and 2012.

      Comment


        #4
        How stupid as it sounds, I think it might have smoothed the whole mesh? I don't understand, because I ticked the Smoothed Groups when exporting it.
        I will try to import the model again, but as a new model to see if that makes a difference.

        Comment


          #5
          Yes. That helped. I made a clean import of the model and it seems to be fixed now. Thank you for helping me.

          Comment


            #6
            This is great! I thought I had to redo it all again! But I can just import the model again and just name it the same and it actually overrides the old character with the new and it has the right smoothing groups! That makes me happy, since that "Reimport Skeletal Mesh" didn't do the thing!

            Comment

            Working...
            X