Announcement

Collapse
No announcement yet.

Problem with normal map

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Problem with normal map

    Hi, i need a help.

    I have a problem with this person of my game, when i applied a normal map texture the problem appears.
    NOTE: The normal texture is a TC_normalmap.
    I dont know, but i think the problem is over normal map, as can see, is showing with color differences according light direction.



    Thanks...

    #2
    How did you create the normal map?

    Comment


      #3
      was used ZBrush.

      Comment


        #4
        and from which 3d software did you import the model?

        Comment


          #5
          went straight from zbrush to udk?

          Comment


            #6
            I don't use ZBrush, but I guess you should try to re-export the normal map using the correct settings:



            Make sure that Tangent is selected. I would also try to turn on FlipG.

            Comment


              #7
              tks, but the problem is, the character artist that done this is not reportable more..
              ****..

              Comment


                #8
                you can try to flip the green channel using photoshop, then reimport the flipped map in UDK

                Comment


                  #9
                  Hum, i will test...

                  tks dude,

                  Comment


                    #10
                    If you used ZBrush there are a few things that you must do before and during UDK import

                    In ZBrush:

                    - Make sure you have the 2nd highest subdivision level enabled, not the lowest or highest - For example if you have 6 subdivion levels you would select level 5

                    - When you create Normalmap make sure you have Tangent selected (Do not select Flip G, this can create issues when importing to UDK sometimes - You will flip G in UDK instead)

                    - After you create the normalmap click Clone NM (your normalmap will show as the current texture) then click Texture in the top menu and click Vlip V from the dropdown (icon with an up and down arrow) this flips the texture vertically, for some reason in ZBrush it's upside down by default...

                    - Click the normalmap texture in the left panel and click Export and use the BMP format


                    In UDK:

                    - Import the texture as TC_normalmap and make sure to check Flip Normal Map Green Channel


                    This should fix the problem but you may still notice some keystoning with higher res textures, this is a problem with ZBrush's export and there isn't really a fix for it

                    Comment


                      #11
                      Hello to all,

                      just want to thank all the advice and tips, we have solved the problem just flipping the green channel, below is a picture of how it is now...



                      and thanks again!...

                      Comment


                        #12
                        I recommend using XNormal - http://www.xnormal.net/1.aspx (Free Software) to generate your Normal and AO maps because ZBrush is notorious for creating very flat and depthless NormalMaps

                        Just export your highest SubD mesh and your lowest SubD mesh from ZBrush and generate the normals from the high SubD mesh to the lowest SubD Mesh in XNormal, you will see MUCH better results, trust me


                        Originally posted by PepeLegal View Post
                        Hello to all,

                        just want to thank all the advice and tips, we have solved the problem just flipping the green channel, below is a picture of how it is now...



                        and thanks again!...

                        Comment

                        Working...
                        X