Announcement

Collapse
No announcement yet.

Texture issue inside UDK

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Texture issue inside UDK

    My textures either looks low res or pastel like inside UDK, which makes for a horrible result.
    Here's some screenshots:










    Any idea how I can correct this?

    #2
    It seems it really has to do with my Normal map. Looking at it in UDK it seems very pastel like. Almost smeared like.

    Comment


      #3
      Your specular map is probably too bright, you also need to add a constant to control the specular power.

      Comment


        #4
        Originally posted by darthviper107 View Post
        Your specular map is probably too bright, you also need to add a constant to control the specular power.
        I get the same result even though I remove the spec map. I still thinks it's the normal map.

        This is how it looks before I import it:



        and this is how it looks after I import it into UDK:

        Comment


          #5
          are you using the right compression settings when you import?

          Comment


            #6
            Originally posted by smokey13 View Post
            are you using the right compression settings when you import?
            I've tried several but I normally use TC_Normalmap.

            Comment


              #7
              Connect your normal to a Multiply A. Connect the B of the Multiply to Constant3Vector. (for the Multiply, press M - for the Constant3Vector press 3) Plug the Multiply into the Normal plug.

              Set the Constant3Vector to 2,2,6, ie: R 2, G 2, B 6. Mess with those settings until it looks right.

              Comment


                #8
                Originally posted by Snipe34 View Post
                Connect your normal to a Multiply A. Connect the B of the Multiply to Constant3Vector. (for the Multiply, press M - for the Constant3Vector press 3) Plug the Multiply into the Normal plug.

                Set the Constant3Vector to 2,2,6, ie: R 2, G 2, B 6. Mess with those settings until it looks right.
                Interesting. I'll get back when I've tried that.

                Comment


                  #9
                  Try to set the compression settings to "TC_NormalMapBC5" if you haven't already tried.
                  Try also to set the LODGroup to "RenderTarget"

                  Comment


                    #10
                    Basically that's just a bad normal map with too strong high frequency details.
                    Tweak your settings for the diffuse->normal conversion or switch to another program for generating normal maps.

                    Comment


                      #11
                      Alright. Testing has been done. Results:

                      Multiply and ConstantVector3 gave much better results, even though there's still some traces of the pastel look. I tried tweaking but had to keep two first variables low.
                      Compression settings didn't do much unfortunately, and neither did LODGroup.

                      I'm gonna try and rerender the normal map as mAlkAv!An suggested. I'm using both Nvidia tool and CrazyBump, alternating between the two. Will get back with results. I really appreciate the time you take answering this guys.

                      Comment


                        #12
                        could you post a link to the actual file for the normal map? I'd like to import it and see if I get the same results as you.

                        Comment


                          #13
                          Originally posted by JessieG View Post
                          could you post a link to the actual file for the normal map? I'd like to import it and see if I get the same results as you.
                          Absolutely! Let me know if you wanna try other parts as well.

                          http://www.megafileupload.com/en/fil...4-NRM-tga.html


                          I made a choice today that to go with more or less plane walls, instead of full 3d walls, and to use nDo2 and dDo for map generation. I think that will solve alot of problems I've had before as well, and hopefully I will won't stumble upon this again, even though every problem is something you learn and get wiser from.

                          Comment


                            #14
                            Sorry it took so long long to reply. Had some things to take care of the last few days.

                            From what I see, I tend to get minor changes to the normal map on import, which is to be expected with the texture compression. As stated earlier, the high frequency detail is really strong. Even toning it down in photoshop with a 50% base normal map blue (128, 128, 255 values for color) still produces somewhat of a splotchy result.

                            I suggest one of two things. 1: make a more closeup tiling version of those bricks and tile them across the mesh so that it will look better when the camera is close to them. Having those bricks all uniquely mapped like that makes for a lower quality when viewed up close.

                            or 2: Adjust the normal map so it only has the major areas such as the crevices between the bricks and large cracks accentuated. All the chipping and fine detail can be done much cleaner with a detail normal map tiled across that.

                            Comment


                              #15
                              Basically everything has been said already. I just want to add a few words again^^
                              Well, your problem is already visible in your normal-map. It is far too noisy and with too much high-frequency details, as my pre-posters have already pointed out. So you should not be suprised to get the rendering results that you showed us in your first pictures. You can of course try to finetune everything inside the material editor, but another way would be to work-up your normalmap in photoshop, gimp or even paint.net
                              All you need is to make a copy layer of your normal map, set the blend mode to "overlay" and blur it a little. Then copy again, overlay and blur again. Do this a couple of times and you will get a much smoother normal map without losing the small details. Here, have a look on this: http://www.cgtextures.com/content.ph...name=normalmap
                              This is a fair quick way to make normal maps better looking, at least in my opinion

                              Comment

                              Working...
                              X