Announcement

Collapse
No announcement yet.

Skeletal mesh normal problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Skeletal mesh normal problems

    Hello,

    I have had lots for problems with this for some time now and I thought id finally post about it. I have googled around and found people having the same problem but I never really understood if they fixed it and how they did it.
    I have created a little picture to try to explain my problems since I am quite bad at explaining. I am using Maya 2013.5 and fbx version 2013. I have deleted history and cleaned up the mesh before exporting.



    I Hope the image helps, this problem really bothers me since I cant get my models to shade correctly. Especially meshes that are mirrored.

    Thanks in advance!

    #2
    Try checking Explicit Normals in the UDK import properties

    Comment


      #3
      Thanks for the Quick reply, I tried it but as far as I can see there is no difference.

      Comment


        #4
        Try turning off Import Tangent, you can also try making your normals explicit in Maya (which means they stay the same even if you modify the mesh). I think there's also a Tangents and Binormals option for import, if it's there, try messing with that too.

        Comment


          #5
          What do you mean by making them explicit in maya? how do I do that? is it lock normals? because I did try that earlier but it simply made most edges hard in UDK.

          Comment


            #6
            It may be lock normals. I'm not sure how it's done in Maya, in Max I can go to the Normal modifier and select them all and click Make Explicit. It's a technique I've used when I need to split a cylinder down the middle but want the normals to make it look like it's still a single mesh.

            Anyways, there's some different normals settings there that you can mess with in the UDK import window. As for your normal map, it might need the green channel to be inverted, I'm not sure, sometimes that's necessary depending on what program made the normal map.

            Comment


              #7
              Thanks for the reply darthviper107, Im gonna try to see if I can find something about explicit normals then. I have the invert green channel box checked and it works like it should on most areas except the mirrored ones and some other areas of course.

              Comment


                #8
                I have tried googling abit but cant really find anything other then "lock normals" but it didnt really work when I imported the mesh in UDK. Here is a pic

                Comment


                  #9
                  If I had to guess I'd say try unchecking in your export options, Smooth Mesh. I don't know Maya exporting but in Max you would only use Smoothing Groups and Tangents and Binormals. My guess is the smooth mesh option is for subdivided models in which case it'll average out the normals and that may be exactly what's happening. On your shot it seems like averaged normals.

                  For importing I think you should uncheck Import Tangents and keep Preserve Smoothing Groups checked. I can't exactly remember now but I think unchecking the tangents is correct. Since you've tried the import settings at different settings without success, I can only conclude that exporting is the problem.

                  An easy way to test is to import back your model in Maya after exporting and see if the normals are correct. My thinking is that they won't be, in which case importing will never work correctly.

                  darthviper107 also mentioned the green channel and I also think the green channel may be wrong in those shots. If you had invert green checked for taking those shots, you may need to uncheck it. It's hard to say without personally looking at it from different angles but keep that one in mind as well if it still looks weird if you get the normals sorted out.

                  EDIT: -- My comments are based on the first shots posted, my post was written before Ulfen made his last post in which case the stuff about the green channel no longer applies.

                  Comment


                    #10
                    Your new shots look quite different and now seems to have just messed up normals and not averaged normals. My previous post may not apply at all. I'm not sure what's going on there. It's not a problem I've ever come across.

                    Maybe you can do the test, importing back into Maya, to see what's happening with the normals. If they come out equally messed up back into Maya or not.

                    Comment


                      #11
                      Okay, I imported the fbx into a new scene in maya and everything seems to work as it should. I also tried unlocking the normals to see if it messed up but it worked.

                      Comment


                        #12
                        Mirrored UVs can be a pain to work with. For static meshes the 'explicit normals' checkbox would have fixed your issues but for a skeletal mesh you probably need some workarounds to get it right into UDK, e.g.: http://www.polycount.com/forum/showthread.php?t=116922

                        Comment


                          #13
                          Ah yes, I will try that again but last time I gave it a shot it didnt turn out right. But Il give it a go later when I get home.

                          Comment


                            #14
                            Holy ****! It works! thanks alot for the help guys, I gave the tutorial mAlkAv!An linked a shot and it actually worked. I got a minor seam where the texture mirrors but I belive it can be fixed.

                            Comment


                              #15
                              uncheck preserve smoothing groups on the udk import options. There seems to be an issue with skeletal meshes and this import options. It might be a bug with the current udk version.

                              Comment

                              Working...
                              X