No announcement yet.

1-2 Tris buged upon import ?

  • Filter
  • Time
  • Show
Clear All
new posts

    1-2 Tris buged upon import ?

    Here is the Setup:
    Using latest blender exporting static mesh as .ase or even in the other formats doesn't change the problem and importing it into the latest UDK.

    Problem Pic & Description:
    The problem is upon import into UDK and putting a texture or wrapper on a model two tris that technically make up one face in blender two tris in the UDK tear from the wrapper/texture alignment and just seem to do there own thing. Sort of just generating there own coordinates or taking whatever image piece they want for display, even twisting it. Please read the rest before responding.
    Pics --> Multiple Images All Same Issue

    What we have done TSing Wise and our Current Resolution:
    Its not a very big problem and I can fix this by adding more faces, but I want to know why this is occurring and if there are better ways to resolve this. Adding more faces when trying to keep poly counts low is not a good solution.

    We have imported a ton of models this way no problems. But every now and then this shows up. The wrapper and seams do not seem to be part of the issue as we even tried not using a wrapper without seams and the exact same problem occurs. We exported/imported multiple times to make sure nothing corrupted during the process.

    Also we have tried flipping the faces inside out and back again - deleting the face and recreating/reconnecting it. I would think that if it was a problem with the dimensions of the face that all the other faces that are identical in size to this face would have the same problem.

    Does anyone have some knowledge that can provide?

    I have seen this problem many times, usually switching to the fbx exporter fixes it. it can also be caused by bits of the UV being outside of the UV space.

    if you use the fbx exporter is the problem exactly the same?

    if the problem is the same could you host the blend file.


      Using FBX resolved the problem.... Sorta feel like a jerk we stopped using that format a while ago.

      Just curious is you can elaborate on the UV being outside of the space? Is there a solution to the issue while still using .ase?

      Thanks Mate


        Originally posted by OSIAS View Post
        Using FBX resolved the problem
        glad to here it

        Just curious is you can elaborate on the UV being outside of the space?
        if any faces are outside of the square UV space when you export your model, those faces are automatically put back onto the UV space by UDK on import which usually causes the material on those faces to be stretched or skewed (like on your pic), but as using the fbx fixed it for you it wasn't your UV anyway.

        Is there a solution to the issue while still using .ase?
        I am not sure if anyone knows why the ase exporter sometimes does this, must be some kind of bug. I don't think there is any solution (or at least im not aware of one).

        Thanks Mate
        happy to help