Announcement

Collapse
No announcement yet.

Help with custom vehicle in UDK Editor 10 2012

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    for one thing you need to change the size for your "wheel radius" in your script and I am not even going to attempt to say why your car is standing on its end, although it does remind me of "tractor tipping" in the film cars.

    Originally posted by DemoMan2 View Post
    BTW, thanks again GeoDav for all that you do for the UDK community!
    I second this

    Leave a comment:


  • replied
    Originally posted by geodav View Post
    ok i could be nasty any say ask the video author for help or google is your friend as all those problems are very common

    to start
    1. your bones may be pointing the right way but are the bone pivots align to world coordinates, as this will fix most of the problems
    2. if exporting via fbx make sure your exporting as Z=Up
    3. you may need to adjust the COMOffset if the vehicle still doesn't sit right

    pics or videos always helps us find your problems

    bottom line is watch my video tutorials as they work !! i also support them
    Listen to GeoDav young grasshopper! GeoDav has saved my bacon on many different vehicle projects. Make sure to check out his "Channel" on you tube. He has lot's of cool UDK videos available for free to watch!

    BTW, thanks again GeoDav for all that you do for the UDK community!

    Leave a comment:


  • replied
    Thanks for the suggestions!

    Hey thanks for the help and the advise! I have watched the GEODAV vehicle tutorial and I'm in the process of adding the "UTVehicleScorpianWheel" but per GEODAV's suggestion, I have bypassed "UTVehicleScorpianWheel" and I'm using UDKVehicleWheel instead. So far no change. I have not looked into the other suggestions yet and will attempt to debug this tonight in class. Currently I do not have an image of the "car" on its side but to answer your question, the "car" would be lying on it's passenger door. Regardless, I do have images of current scenario; of the the custom vehicle before and after invoking the "play from here" command in UDK Editor. Meaning, the "car" goes back on it's back bumper when you test it, you can see it move from its expected stance and view it going up on its back. I included a shot of the UnealPhAT asset too. Thanks again!


    https://skydrive.live.com/P.mvc#!/?c...5F0CC3EE21!104

    Leave a comment:


  • replied
    ok i could be nasty any say ask the video author for help or google is your friend as all those problems are very common

    to start
    1. your bones may be pointing the right way but are the bone pivots align to world coordinates, as this will fix most of the problems
    2. if exporting via fbx make sure your exporting as Z=Up
    3. you may need to adjust the COMOffset if the vehicle still doesn't sit right

    pics or videos always helps us find your problems

    bottom line is watch my video tutorials as they work !! i also support them

    Leave a comment:


  • replied
    as well as those 3 scripts you also need the "UTVehicleScorpianWheel" script. when you say the vehicle is positioned on the side of its chassis, do you mean its leaning over to one side?. for the camera I think you need a custom camera class or for quickness add a socket to the root bone and call it "GunViewSocket". to stop the wheels flopping end over end try changing the "roll axis" in the wheel skeletal control.

    --EDIT--

    forgot to say, GEODAV has tutorials for setting up vehicles in UDK.

    Leave a comment:


  • started a topic Help with custom vehicle in UDK Editor 10 2012

    Help with custom vehicle in UDK Editor 10 2012

    Hello,
    I’m using UDK Editor 10 2012 and 3Ds Max 2013 for a school project. Does anyone know of a definitive custom vehicle tutorial or might know what I am doing wrong? I only want my custom vehicle to move correctly as a Scorpion does with the WASD keys.

    I have followed the below video link tutorials for creating and exporting custom vehicle rigged from 3Ds Max import into UDK without success. I have also read the UDK Vehicle Technical Guide. I can successfully import a skeletal vehicle mesh and successfully place it in a level but it will not work when I attempt to test and play level. I do have a AnimSet, AnimTree, Phat, and Phisics. Note, in regards to these “sets” and I have verified that I have the same values per the Scorpion’s AnimTree asset, AimSet asset, Phat assest, etc...

    The results of problems listed are below after debugging attempts and re-doing from scratch about five different scenarios happen when I test and play the level;
    • The vehicle appears ok but does not respond when command E is depress
    • The vehicle “stands up on end” with back bumper down and front bumper up and does not respond to command E key
    • The vehicle is positioned on the side of its chassis although it was originally “right-side up” when first placed into the level. Vehicle does not respond to command E key.
    • Or if vehicle does respond and moves via WASD keys, the vehicle will always be on it’s side, the camera is far away and the vehicle moves sideways via W and S keys and Forward and backward via A and D keys as the wheels flop end-over-end instead of rotating.

    In both 3Ds Max’s and UDK, I have verified that I have the Main_Root and wheel bones pointing correct direction of positive “X” coordinate and that the “Z” coordinate is “up.” I have verified proper wheel displacement and rotation in the AnimTree asset. I believe I have correctly followed instructions via http://udn.epicgames.com/Three/SettingUpVehicles.html with the exception that I’m keeping it simple with only five bones, Main_Root and four wheels that conform to suggested naming conventions. I'm not using any suspension, weapons, morph info, or damage info for my vehicle. I only use the Main_Root bone to define a socket in the Animset assest. Moreover, the other exception is that I am creating the three scripts below.

    Via web tutorial http://www.youtube.com/watch?v=KIV6uaeL5IQ at 34:52, I created three new files and modified them with my vehicle skeletal mesh name:
    UTVehicle_Scorpion_Content.uc
    UTVehicle_Factory_Scorpion.uc
    UTVehicle_Scorpion
    http://www.youtube.com/watch?v=Gabf2Q4qdDo
    Thanks for any replies!
Working...
X