Announcement

Collapse
No announcement yet.

Static mesh lighting seams

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Static mesh lighting seams

    Hey guys,

    I have a problem with my tileset-meshes I want to use to build up buildings in my map. Well, I created perfectly aligning props with (nearly) perfectly seaming textures that should allow me to build versatile houses and up to a certain point it works fine. The problems are coming when I build the lighting with lightmass -> it creates lighting "bugs" (?) showing the seams between the single meshes.
    Have a look on this screenshot, I think it shows what I mean:



    As you can see, it's quite OK in unlit mode, the lightmap however does not work well..
    How I proceeded:

    - create static meshes with autodesk softimage for simple wall, wall with window, wall with door etc.
    - Use one large 2048 texture for diffuse; all meshes are sharing this one.
    - Every mesh has it's unique "complete texture space using" lightmap
    - Export the mesh to UDK, using hard edges for the corners so that lightmass is not trying to fake round corners of the meshes

    Can you tell me what else I have to do to get my meshes perfectly seamless? I also tried to make the lightmap "pixel accurate" so that there are no half pixels at the corners but it did not really help. And I checked the epic meshes and those aren't pixel accurately lightmapped either.. Ah, yes, and the bug shows up with all lighting quality levels, although it is worst for "preview" and best for "production".
    If you need further information, just tell me! This issue really kept me busy for quite a time and I really need to get it fixed^^

    Many, many, many thanks in advance,

    Hackmet

    #2
    1st of all- 1 texture - all that mesh- wow; i hope someday i can achieve such cool optimisation, incredible.

    - 2nd i don't really think you are showing the problem, or what you are trying to achieve.

    - i will say this - the 2 sticks you have poking through the fabric above the door- are not casting shadows on the floor- but the fabric does.

    - That is the only problem i see; please confirm if this problem is 'what you are talking about', because i am interested in this and finding/ seeing a solution.

    - p.s. - sounds like this will be great work when your finished- good luck


    **** The only obviousness for this is
    a) You have a lightmap resolution set to default
    b) you have not set F4 > Properties > Override lightmap-- to false

    - OR//// &///
    C) your lightmap resolution not correct valur for the distance you are stood... E.G... Lightmap is 512 ; are you image was taken standing like 4096 units away - get closer,
    ^^ this is what i mean by hard to tell what you want to do....

    Comment


      #3
      Hey man, just focus on the leaves shadow on the wall. You can obviously see the lightmap res is extremely low. I guess it's about =<64. You just need to increase it.

      Comment


        #4
        Originally posted by TKBS View Post
        1st of all- 1 texture - all that mesh- wow; i hope someday i can achieve such cool optimisation, incredible.
        It just need some planning in advance, then it's actually not much harder than having separate textures for all meshes

        Originally posted by TKBS View Post
        - 2nd i don't really think you are showing the problem, or what you are trying to achieve.
        OK, let me explain it again:
        I want to have house walls (or frontages) built out of the different parts, e.g. simple walls, window parts, doors, whatsoever. I created the single meshes and as you can see in the first picture (unlit) it works well - you cannot see that the wall is actually composed of many sub meshes. However when building the lighting (see last picture) you see quite clearly where one mesh stops and the next begins. I need to get rid of these shades there at the corners of the edges...

        Originally posted by TKBS View Post
        - i will say this - the 2 sticks you have poking through the fabric above the door- are not casting shadows on the floor- but the fabric does.
        I guess this is due to different light map scales on the walls and on the floor (which is a brush structure for simplicity). But this is not the main problem, it is more the shading bugs on the wall


        Originally posted by TKBS View Post
        - p.s. - sounds like this will be great work when your finished- good luck
        Thanks, Iam doing this for a quite interesting multiplayer mod called CrushingGods. If you want, I can support you with more information, but our homepage is unfortunately only in german since we are a german developer team..


        Originally posted by TKBS View Post
        **** The only obviousness for this is
        a) You have a lightmap resolution set to default
        b) you have not set F4 > Properties > Override lightmap-- to false
        Thanks, Iam going to check for this!

        Originally posted by TKBS View Post
        - OR//// &///
        C) your lightmap resolution not correct valur for the distance you are stood... E.G... Lightmap is 512 ; are you image was taken standing like 4096 units away - get closer,
        ^^ this is what i mean by hard to tell what you want to do....
        There are different lightmap scales in dependency of the "viewing distance"? Didn't know this... How can I control this?
        But nevertheless, this error also occurs when Iam literally running into the wall!

        Originally posted by quytin1992 View Post
        Hey man, just focus on the leaves shadow on the wall. You can obviously see the lightmap res is extremely low. I guess it's about =<64. You just need to increase it.
        I'll check for this this evening. I tested different light map scales and it definitely gets better with higher resolution but I thought it should work at lower scales as well. And Iam quite sure that this is true for the stock epic meshes.
        And I just was concerned of getting a too high scaled lightmap because I want to build sort of a whole town out of such meshes and I would have to use a very high light map resolution everywhere... Isn't this leading to memory overloading? I walked around the epic maps and looked on the light map resolution and it's in average not that high.
        Do you have any recommendations? This is the problem of being originally a source-engine mapper - many things are different in the unreal world and I still have to learn a lot^^

        Thanks for you advices,
        best regards,

        Hackmet

        Comment


          #5
          Firstly, make sure that the normal maps are fine. It's usually beveled along uv borders. Secondly, you can mess with the light source settings or replace it with the others. Finally, it would be nice if you could upload some screenshots of your lightmaps. Cheers.

          Comment


            #6
            So far Iam not using normal maps, I firstly wanted to make sure that it works without. I will add normals in the next step. I attached two screenshots of the used layouts. The first one shows the diffuse layout of the whole tile set in xsi. The second shows of one mesh the diffuse and lightmap uv layout in the UDK.


            Comment


              #7
              Your lightmap UVs are way too tightly packed. You need a lot more distance between the UV islands (also known as padding). Your problem is most likely bleeding artifacts.

              Comment


                #8
                Have you tried not making so many modular pieces. I would make that entire wall one piece use a texture coordinate to scale the texture to a reasonable detailed size and make the windows and doors all separate modular pieces place them agains the wall and get maybe some decal textures in there or use the material editor to place so detail on the wall and on the modular pieces. but that's just me.

                Comment


                  #9
                  Are you baking with "production lighting"? Anything lower than that is significantly faster, but produces far worse results with lots of lighting artifacts, if you are, try rebaking with "production" quality.

                  Also, what Rodesqa said. You could try making whole wall a single mesh, but with multiple polygons so that you could tile your textures properly. Also, separate lightmap shells shouldn't be too close to each other in UV space.

                  Comment


                    #10
                    Your problem is lightmap, it needs to be lined up to grids in your 3d software then you won't have shadow bleeding .

                    Comment


                      #11
                      Definitely agree with the fact that your light map is too tightly packed. I'll update the thread with a list that has the optimal padding based on light map resolution whenever I find what I did with it. Try and give everything ... I want to say at least 4 pixels of padding at 64 res light map. Also make sure that you're running 'Production' lighting as mentioned above. I remember wasting a lot of time trying to figure out why I had light seams even after I spent so much time trying to fix them. I had been using the preview lighting for speed, but didn't realize how poor the lighting quality is compared to production.

                      As far as lining up with the grid goes it doesn't hurt, but there will be situations where you just won't be able to do it with certain shapes. You could probably get away with the shapes you have, though. To get the UV grid size for your light map resolution just take the resolution you're going to use and divide 1 by it (So light map resolution 64 = 1/64 = 0.015625).

                      I'm half asleep so I'm not sure if I skipped too much.

                      Comment


                        #12
                        Damned, I thought I would get mail notifications for new answers. Just looked over here occasionally...

                        Well, thanks for your additional help -> I wasn't aware that the lightmap UVs must not be packed so tightly. I tried to use the space as efficiently as possible^^
                        Iam going to try less densely packed ones!

                        I also observed that the lighting quality does have a huge impact on the quality. As far as I remember, I baked with "production" quality for the screenshots shown above.

                        Concerning the "less modular approach" by using large meshes/brushes for the walls and smaller assets for windows etc: This was actually my first attempt when I started to build the level. However, I was not satisfied by the results :/ Dunno, maybe it is the fact that by this I cannot have windows going "inside" the wall or something, but it didn't look well to me. But if you have advices for this workflow, Iam still opened for everything that could help

                        Comment


                          #13
                          A useful read, with good pictures too: http://udn.epicgames.com/Three/LightMapUnwrapping.html

                          Comment

                          Working...
                          X