No announcement yet.

Error Importing 3d Model into UDK.

  • Filter
  • Time
  • Show
Clear All
new posts

    Error Importing 3d Model into UDK.

    So I have this t-rex 3D model that I am trying to get in UDK for a machinima project, and no matter what I do I cannot get it to import correctly.
    I have no idea what to do and could use some help.
    I have no idea how to describe it, so I will show you in pictures. The Trex looks the way it is supposed to look ONLY when it is in the Render screen of 3DS max. As seen here:Click image for larger version

Name:	3DSinRender.jpg
Views:	1
Size:	82.6 KB
ID:	3253359
    It looks like THIS:Click image for larger version

Name:	in 3Ds Max.jpg
Views:	1
Size:	75.5 KB
ID:	3253360 when I am editing in 3DS max and is always green.
    Here is what it ends up looking like in UDK:Click image for larger version

Name:	inUDK.JPG
Views:	1
Size:	91.3 KB
ID:	3253361. As you can see, it gets smeared up and all destroyed. No textures either. As you can tell, I am sort of a noob, haha.
    Also, I am using 3DS max 2013, with xactor for 3DS max (as seen here: Click image for larger version

Name:	settings to check.JPG
Views:	1
Size:	55.6 KB
ID:	3253362), and using windows 7 64bit in case you needed that information...

    Thanks in advance for the help!!

    It looks green in the 3ds Max viewport because the texture isn't enabled to show in the viewport, in the material editor you can enable it by turning on the little checkered button.

    It gets messed up in UDK because there's too many polygons, there's a limit to the size (in terms of number of polys) that you can import to UDK. UDK is designed for game content so stuff that gets imported is typically way below the limit. For exporting, I recommend using the FBX exporter, to get the textures in there you can import them to UDK separately and apply them with a new material to the mesh, or if you use FBX you can apply them as a material in 3ds Max and then in the import options in UDK make sure it's checked off to import textures and materials. It doesn't include all the features of the material but it will import most of your textures. That is, as long as it's the right format and the texture dimensions are a multiple of 2.


      as Darthviper107 says it looks like you mesh has a way to high poly count, but you also need to sort your export settings

      Skin Export
      tick "all skin-types" & "textured"

      tick cull all unused dummies

      even for matinee i don't think it would be a good idea to go over 40-50k triangles maybe 60-70 at a push, but i've never tried that far


        In addition to what have been told above. I do have deja vu when I see picture of Your problem. I vaguely remember I encountered this once using ActorX and if i recall things correctly the problem was doing changes on biped after the geometry mesh was rigged onto. If I remember this correctly the problem was caused by either adding tail or pony tail. So my conclusion is if You modify the biped structure by adding additional biped parts (or perhaps remove those not needed) the 3ds max works fine, but Actor X somehow strangely things these parts are there and this cause the vertex assignment mess.


          I haven't go back to material in long time but this is not the end of world. I've encoutered your problem countless times and found a solution which I sort of forgot.

          One thing I can say is that it is a normal problem.

          Just like geodav said, when importing make sure

          Skin Export
          tick "all skin-types" & "textured"

          Ok before you export, you need to apply the normal fix.

          Make a backup first please, so I don't stuffed up your work.

          1st step is to apply "Reset XForm" on the whole model. (If you have different UV set, make sure to group them first)

          Applying Reset XForm:
          in 3D max there is a hammer icon on the far right of the tool (it has asset browser camera match , etc)
          Select the model you want to fix and click on Reset XForm

          After that Convert it to editable poly.

          Applying "Normal" :

          Select the model and find normal modifier.

          Depending on the problem you might want to flip the normal. Check unify normal as well.


          Export again with ActorX, if the model still broken, then try to thich/unthick the flip normal in correspond to the previous value.

          If this does't fix, then make sure you have smoothing group assigned on the model.

          Again, I only vaguely remember how to fix this. Sry for the bad english and I hope this help you.


            I could never get that model working, so I tried another one, did everything you guys said, and still cannot get this model working either. Can someone just take THIS file in 3DS max, and get it looking good in UDK and make it a .upk file for me so it is ready to USE and make animations for?
            That would save me a LOT of time because I am soooooo out of my element with the modeling portion of this...
            Feel free to keep a copy of the model (that I paid for) as a prize for helping me!