Announcement

Collapse
No announcement yet.

Importing .FBX meshes in UDK

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Importing .FBX meshes in UDK

    Hi!

    I'm still trying to learn UDK and since I've heard good things about Blender (and I love free software, even UDK is free after all), I've started using it.
    However, when importing the .FXB file, UDK shrinks the model down to a ridiculous size (smaller than the head of a normal character model like liam or ironguard)
    and also the orientation is wrong. However, the bones seem to be the right size when using scaling in the export dialogue.

    The mesh and bones look fine when using the built-in FBX viewer in Autodesk FBX converter (which I'm using to prevent UDK from complaining about the FBX version).
    I've also tried not using the converter, but I keep getting the same problems. Could this be a UDK problem? Since it looks fine in the Autodesk program?

    I've tried installing scripts for PSK/PSA export in Blender, but they either can't be enabled or don't show up at all in the add-ons list.
    Anyone else having the same problems? =/

    I tried using Maya to export the mesh, which solves the size problem if I use scale factor 10, but the mesh is still pointing the wrong way in UDK no matter how I rotate it in Maya.
    Even if I can get around that proble, it's a shame having to buy Maya just to use it for conversion. =/


    Blender:
    Mesh
    Export dialogue

    Converter/viewer:
    FBX Converter
    FBX Viewer (Note how the bones are still right)

    UDK:
    Mesh
    Bones (the mesh is obscured by the hand bones)
    Ironguard (for comparison)
    Mesh (zoomed)

    #2
    1 blender unit = 1 unreal unit
    Also check my sig for the relevant thread.

    Comment


      #3
      blenders default grid is 16x16 units witch means your model is about 16-18 units tall so its not being shrunk in UDK its the size you made it in blender, you should apply scale to the mesh, blenders fbx exporter doesn't know witch way up/forward is even if you set it in the settings so if you do use it you need to do what SPOOF says. the psk exporter is already installed in blender 2.65, it should already be active, if its not go to "addons", select "import-export", then tick the box for the psk exporter and then save as default. also blender 2.66 has a couple of extra features for the psk exporter so you might want to upgrade.

      hope this helps

      Comment

      Working...
      X