Announcement

Collapse
No announcement yet.

another collision issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    another collision issue

    Hi Everyone,

    Posted this in the Level Design forum but didn't get a lot of help, thought I'd try here, so sorry for the repost

    I'm having issues importing meshes with collision into UDK. I've made plenty of models in the past and modeled collision into them so I'm fully aware about naming the colli prims to UCX_modelName_00X (X being an additional number for each additional prim), making sure they're convex rather than concave, having no open faces, etc... but now when I do what I've always done, the mesh comes in but not the collision. I've tried changing the naming method of the collision prims to being UCX_modelName00X, UCXmodelName00X, even just creating a basic cube, naming it UCX_test and UCXtest, and I just can't seem to get the collision to import.
    Just FYI, I'm using Maya 2012 x64 and installed FBX2012.2 so the Maya FBX plugin is the same version of FBX that the version of UDK I'm using is running (January '12), as well as trying newer version of the Maya FBX plugin.

    Any advice/suggestions would be greatly appreciated.

    Thanks!

    #2
    Wasn't Maya 2012 released AFTER the January 2012 UDK beta? Have you tried changing the FBX version drop down when you export to 2011?

    This is the naming convention that has worked for me (and still works now):

    Mesh name: MeshName
    Collision Mesh name: UCX_MeshName_01

    Have you also made sure to delete the history and freeze the transforms of both the mesh and the collision model before exporting?

    Comment


      #3
      Hi Jessie,

      Thanks for the response. I tried downloading the 2011fbx plugin, it was only able to load in Maya 2011, which I luckily still have installed. Went through the process and no dice. At this point when I import the mesh the engine pops up a message saying the version of FBX im using is outdated, didn't get that with the previous version.
      I did freeze transforms and delete history before exporting.
      Just for the sake of experimenting I just created a single standard cube, didn't translate, transform, etc..., named it UCX_cube_01, exported, imported and it gave me an error saying import failed.

      Are there any specific boxes in the fbx export options that have to be checked?

      Comment


        #4
        Make sure pretty much everything in the "include" options is turned off. I always have tangents and binormals and smoothing on but other than I don't include anything else in the FBX export (I prefer to bring textures separately from the FBX to allow for easy reimport). I don't know how big of an issue it may be but I also make sure the up axis is set to Z in the export settings as well if I worked with Y up.

        Try disabling any extra content that may be checked on in the export and see if it helps. If not, I'll go through my FBX settings and take screenshots of how it's all set up on my end. If even THAT doesn't work then we can at least have the issue narrowed down to some technical hiccup and not something you may be doing incorrectly.

        Comment

        Working...
        X