Announcement

Collapse
No announcement yet.

UDK Crashing on FBX import

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    UDK Crashing on FBX import

    Hey everyone!

    So I've been working with UDK for about a year now, and I haven't run into this problem before. I created a mesh inside of 3Ds Max 2013, textured it (Textures saved as .psd, also tried .tga), did the light map, smoothed it (with smoothing groups), and exported it as a .fbx

    When I export it as a .fbx, I get "The polygon mesh contains invalid faces and needs to be corrected by the application.
    The following nodes are affected:
    -Box001"

    I just clicked okay and moved on. I went to import into UDK, and if I import WITH the textures, it says that my textures aren't the power of two (they are all 3,072 (Big, I know, but it's a bigger model)), then when I click okay, it crashes, and I have to force close it in the task manager.

    If I import WITHOUT the textures, UDK just straight up crashes, and I have to force-close it again.

    Help would be much appreciated!

    -Hamstamps


    System is:
    Windows 7 Home Edition 64-bit
    Intel Core i5-3570k
    Gigabyte Z77X-UD3H
    2 Nvidia MSI 465's in SLI
    8GB DDR3 1666 RAM
    Seagate 1TB 7200RPM 6.0GB/s

    #2
    make them 1024x1024 or 2048x2048 or 4096x4096 and try again...

    I also recommend to use .tga (or .png if you want to save space on the disk, but they must be 8-bit depth)

    Comment


      #3
      That warning sounds like you have some dirty geometry. There are a number of cleaning steps you can do when geometry has been corrupted:

      - Select all verts and weld. Helpful to ensure that welds were done correctly to make the mesh more contiguous. A good safety catch but use cautiously, if you've got some twisted geo this could make it worse.

      - Remove Isolated Vertices (Editable Poly > Vertex Mode). If you've got floating verts this will kill them.

      - Add a Normals Modifier and click "Unify Normals". This will also help vertex alignment issues.

      - STL check. This modifier can be used to find common problems like open faces (where you don't want any) and overlapping geo.

      - Utilities > Reset Xform. Used often to fix scale problems... a mesh should always have it's transforms reset if it's been scaled or had it's pivot moved.

      - UV Unwrapper > Relax. Sometimes I'll do this as a quick check. If the Relax tool is freaking out in places you'd expect it to be smooth it could indicate places where geometry is a mess. Delete and rebuild trouble spots.

      - Always work with Backface Culling on... there's even a place in preferences where you can make this default on object creation.

      - Create a clean mesh (like a sphere primitive), convert it to an Editable poly, and attach your mesh TO it... then deleted the sphere element. This can help eliminate bad metadata.

      - Worse case scenario: Export as OBJ or FBX and import it into a new file. This is the equivalent of nuking it from orbit... it's the only way to be sure. The reason you do this is because the problem could be in te Max file itself, not the geo. It happens.

      Comment


        #4
        Convert the object to Editable Mesh bro.
        And then try to export it again.

        Hope it works.

        Comment

        Working...
        X