Announcement

Collapse
No announcement yet.

[3ds Max users]: Skeleton "problem" with CAT

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    [3ds Max users]: Skeleton "problem" with CAT

    I'm using 3ds max 2013 and UDK (November 2012, i think). I started rigging my character with the Cat Animation Toolkit in this pose:





    But since i'm using 3ds Max with motionbuilder, I need my character to be in the standard HumanIK T-Pose, so i turned my Cat Setup pose in the t-pose:





    no problem at all till now, but when I import my skeletal mesh in UDK (just to try, as long as I haven't finished skinning the entire body), In the AnimSetViewer The skeleton return to the original pose, although I exported it in the t-Pose:



    To be honest, now this isn't a real problem as i tested some animations in unreal and everything seem to work fine, but i had similar problems before (like arms floating and other stuff like that), so I would like to know why my "skin Pose" change during the transition form Max to UDK..

    #2
    I don't know the answer specifically but two questions for possible reason.

    1. Did you reset the skin after t-pose?. (meaning, is the model physically t-posed, even without the skin applied, before you skinned it on the new t-pose).

    2. Did you pose the CAT rig as a new layer or in edit mode?. (not even sure if this matters but, you never know, since I never tried it before I just list it as a possibility)

    These are the only reasons I can think this would happen is that your original skin was done at the arms-down pose and Max can certainly remember that and may possibly be what is exported. So unless you reset and make sure the t-pose is your original skin pose, this may be the problem. Like I said, I don't actually know but just my best guess.

    Comment


      #3
      that certainly is the point: in fact my editable poly right under my skin and morpher modifier is not in t-Pose, the model was skinned in the other pose, but what do you mean by "resetting the skin"? do I have to re-skin all my model starting from the t-pose? isn't there an easy and quick way to achieve this without losing my weight info (because i didn't use envelopes and i manually changed vertex influence)? I can't find anything like this in the skin modifier panel...

      Comment


        #4
        Yeah, it could be possible that by default it's reading just the mesh and it wouldn't get to the T pose until it starts reading an animation

        Comment


          #5
          Yeah, you can easily reset the skinning based on existing info.

          You select the mesh, in the stack, right click on skin modifier and copy it, then collapse the stack. Doing this will keep the mesh in the existing pose. If you delete the skin, the mesh will pop back into the arms-down pose so make sure to collapse it with the skin modifier still in there.

          So, now you have the clean mesh and you've copied the skin. Make sure again the mesh is selected, then in the stack, paste back the skin modifier you copied. Now you'll see the mesh will get slightly screwd up since the new skin pose and old skin pose are different. To fix this you select the mesh, then select the skin modifier, go to the Advanced Parameters, you'll see there's an option called Always Deform, just uncheck that and then re-check it. The mesh will pop back to the correct pose and will be properly skinned as before.

          Comment


            #6
            thank you, that worked! I didn't know I could copy modifier this way, what i did before was collapsing the stack and rebuild the skin from zero... thank you!

            Comment

            Working...
            X