Announcement

Collapse
No announcement yet.

Character rigging Issue...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Character rigging Issue...

    So well i have the following character



    I named every bone as the UDK skeleton but when i export to UDK it looks like this when i try to apply an animation




    I alredy tried playing arround with the names,rotation etc but i havent been able to fix it .. I can provide the files if needed if someone could take a look at them

    #2
    i take it you haven't include the b_ik_ feet bones

    if your using custom anims you don't need to use the ut3/udk rig bone names

    Comment


      #3
      i did include the ik bones but when i moved the leg controller it would lift everything except the feet, so i linked it to the leg and then the upper leg and now its causing the issue in the screenshot

      and yeah im using custom anims but they alredy have been done with the UDK Rig so thats why im in the process of rigging to the UDK rig rather than a custom one

      Comment


        #4
        One of the first things I always suggest with this kind of error.. Check your skinned mesh scale which is the number at the bottom.. If it's not 100 then oopsies..

        To fix this with the possibility of saving your skinning: go into the skin modifier and at the bottom save the skinning file. Then delete the skin modifier and reset your meshes xForms. Put a new skin modifier on and load your skinning file. I'm unsure if that will work, technically it should..

        Let me know if that was it.

        Comment


          #5
          Originally posted by darthwilson View Post
          One of the first things I always suggest with this kind of error.. Check your skinned mesh scale which is the number at the bottom.. If it's not 100 then oopsies..

          To fix this with the possibility of saving your skinning: go into the skin modifier and at the bottom save the skinning file. Then delete the skin modifier and reset your meshes xForms. Put a new skin modifier on and load your skinning file. I'm unsure if that will work, technically it should..

          Let me know if that was it.
          That, or the vertices is skinned to the wrong bone. This sometimes occurs if you don't play with the weights and all. If you click one of those lines on your skin modifier, you'll see a capsule covering a part of your model. Some vertices might not be covered by the capsule and got skinned with another bone, like suddenly the foot is skinned to the pelvis instead of the ankle.

          Oh, and one more thing. Do not modify the capsule. Just use the weight tool to fix the rig, assume if you don't know that yet

          Comment

          Working...
          X