Announcement

Collapse
No announcement yet.

Inside of building not showing

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Inside of building not showing

    When ever I place a static mesh that I want to drive/walk through on the map the inside does not show, the whole thing is visible from the outside but when I go inside the model through the door I made the whole thing is see through. Any ideas on how to fix it? I export my static meshes as FBX files from Maya.


    #2
    Are your faces facing the correct way? Is your material 2-sided?

    Comment


      #3
      I have built the model so that it has an outside wall and an inside wall. Sorry I am a n00b at this. How would I know if the face is facing the right way?

      Comment


        #4
        I use max, but if I remember right I think people with maya have trouble with this. In Udk assign the mesh a material and make that material 2-sided. If that allows you to see all ow the mesh then the faces of part of were facing the wrong way in maya. I think by default maya must render everything as 2-sided or something.

        Comment


          #5
          Your face normal are flipped. Fix that and re-import.

          Comment


            #6
            how do I change my face normals? I did the thing in UDK making a material two sided and that fixed it but I am interested in seeing how to fix it Maya. Thanks for the help so far.

            Comment


              #7
              Select your mesh in Maya and in the top menu in go to Display > Polygons > Face Normals. Little Green lines will pop out of each face on your model showing which way the face normals go. Select the individual faces that are facing in the wrong direction and with the Polygons Menu set open, go to Normals > Reverse. This should flip the lines in the proper direction. Go to Display > Polygons > Face normals again to turn the green lines off.

              I suggest you make custom shelf buttons for displaying the normals and reversing them to make things faster for you later on. I use these options all the time.

              Comment


                #8
                Thanks! That worked and it all looks awesome now. Thanks again

                Comment

                Working...
                X