Announcement

Collapse
No announcement yet.

Need help from 3DSMax Users! Material Error. Looks awful in UDK.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Need help from 3DSMax Users! Material Error. Looks awful in UDK.

    Ok I made this model in 3DSMax:



    I have 2 problems, see how the test material is stretched in some faces, perfectly fine in others and no existent on even more.

    How do I fix this problem?

    Second is on export and import. I know how to do it but for some reason whether I export as FBX or ASE, when I import it into UDK it adds a million more edges that were not in the Max file.

    Any help would be appreciated! Thanks!

    #2
    You need to unwrap the UV's of you rmodel. You can also try doing a simple box mapping.

    As for extra edges, either you're doing something weird, or it's just triangulating the mesh (which is normal), hard to tell without a screenshot.

    Comment


      #3
      Originally posted by darthviper107 View Post
      You need to unwrap the UV's of you rmodel. You can also try doing a simple box mapping.

      As for extra edges, either you're doing something weird, or it's just triangulating the mesh (which is normal), hard to tell without a screenshot.
      Ok understand the triangulation, that is fine. But what about the settings in 3dsmax, why is the texture getting messed up.

      Comment


        #4
        Because you adjusted and extruded the model but didn't create the UV mapping.

        UV mapping is coordinates for your mesh that figure out how to map a 2D image (your texture) to a 3D object. It flattens out the object. By default the mesh primitives have mapping (like a box) but once you start extruding and modifying the mesh you're creating new geometry and it doesn't have any information on how to map it.

        You can map it by either using a UVW Map modifier for very simple things, or go into more detail using a Unwrap UVW modifier.

        Comment


          #5
          You need good UV coordinates on your mesh. The texture is fine, the UV coordinates are not. Try what darthviper suggested and apply a simple box map and check that out (UVW channel 1 in Max).
          when you export, be sure to "export selected" if there are other objects in your scene that you don't want to export.

          Comment


            #6
            You need to learn to unwrap properly period.. Sorry for being mean but thats what's wrong. Your coordinates are skewed and needs to be manually done.

            If your stuck with un-skewing them then flatten everything and begin stitching!

            Comment


              #7
              Thanks guys, got it working, just a small problem, when I exported the uvmap to Photoshop and textured it then imported it to UDK, when I apply the texture I get the grid lines on the model, did I forget to do something in Photoshop?

              Comment


                #8
                Paint on a seperate layer and turn off your UV map under it when you save it out. You might need to make a solid color layer for that.

                Comment


                  #9
                  Originally posted by Tearl View Post
                  Paint on a seperate layer and turn off your UV map under it when you save it out. You might need to make a solid color layer for that.
                  Thanks alot for the help, everyone.

                  Comment

                  Working...
                  X