Announcement

Collapse
No announcement yet.

how to smooth surface the low poly Character

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    how to smooth surface the low poly Character

    aloo

    i want to make low poly character so i bake material from High Poly to low poly in 3d max
    and the map texture i get

    and i export using actor X

    in UDK Material editor



    but the result very different when i rendereing in 3dmax




    still not smooth
    so how to make it smooth?

    #2
    I believe UDK splits the mesh up along seams, so parts you want to be smooth needs to be on a single UV Isle, that's assuming you also got the smoothings groups right.

    Comment


      #3
      Also, it looks like you didn't import your normal map with normal map compression, if you don't do that then it doesn't read the normal map correctly.

      Comment


        #4
        Originally posted by aitchan View Post
        still not smooth
        so how to make it smooth?
        My best assumption is that you are not importing it correctly, there is an option while you import to UDK that is off by default is something named "explicit normals" or some like that (can't remember and I'm lazy don't want to launch UDK) just check the import windows for the option (I had the same problem some time ago and fixed that way).

        Comment


          #5
          Make sure smoothing groups is checked when you export the fbx from 3ds max.

          Before you bake your normal map make sure that every uv island is on its own smoothing group.
          When you import also make sure its set to normal map compression (if you import wrong and change that setting after it will still be messed up so be sure to set it on import)

          Also a common issue is the green channel of your normal map could be flipped

          Comment


            #6
            I've been having that problem with the udk may 2011. I usually have to soften edge maya after skinning the mesh to the jointsx. that solve the problem.

            Comment


              #7
              Yup, as already pointed out, this should be most definitely a normal map problem (the problem zones are exactly where your UV seams are). Easy way to try that is just to remove the normal map in the shader.

              If thats the problem, then you have to redo the unwrap. Characters are often split only at their backside (with the head and other extremities separated) and have a single UV island across their front (most important) and side.

              Comment


                #8
                There's no problem other than that the normal map isn't using normal map compression settings--otherwise in the material editor the blue of the normal map would appear much more saturated.

                Comment


                  #9
                  The normalmap does look kinda strange to me though. I seems like all you hard edges in your UDK model are originating from you normalmap.
                  Maybe this happened when you were baking the normal? Did you set up those smoothing groups correctly?

                  Comment


                    #10
                    solved

                    after i give smoothgroup before export it and change compressing setting in normal map texture now my low poly character like the high poly character has smooth surface.
                    thank all people who give advice. Its help me alot

                    Comment

                    Working...
                    X