Announcement

Collapse
No announcement yet.

Shadows Not Behaving Correctly

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Shadows Not Behaving Correctly

    There is something weird going on with my shadows and I don't understand what is wrong.
    It would appear that in game UDK is rounding out the edges of my surfaces to a weird degree, in the picture you can see the yellow arrow indicating the direction of the sun, down and towards you but the shadows would indicate otherwise.
    Now looking at the back of the frame (1) where there should be no direct light there is a gradient of light down to shadow across this flat surface.
    My Normals are correct, I've checked them enough, and this only really seems to happen when I have a Normal Map plugged into my Material (it still happens when there isn't one but it's barely noticeable). My Normal Map should be fine and it doesn't seem to make any difference to the shadows when I make massive changes to the normal map.
    I am using Blender and I have set everything to flat.
    I've played around with Lightmas and Light Environment settings in World Properties and nothing seems to be making much of a difference with this issue.

    any suggestions?

    (be gentle, it's my first post)


    #2
    Your smoothing groups are wrong

    Comment


      #3
      Thanks, the shading is more realistic now.
      I had previously tried using smoothing but after trying out the method in a tute I found before I saw that he used the "Edge Split" Modifier after applying smooth/flat and that made the difference. I manually cut it up when laying out the UV map but apparently that didn't do anything.

      Unfortunatly though after fixing the shadows I'm getting this one vertex that's getting thrown out into the middle of nowhere. It looks fine in blender but when I import it into UDK it looks like this:

      Comment


        #4
        Now I just realised that I didn't have the Normal Map plugged into the material since my first post so the problem hasn't gone away at all and now whenever I export a new model it's throwing that one vertex up and out the back.

        Any ideas?

        Comment


          #5
          Have you imported your normal map correctly? You need to make sure you're using Normal Map compression otherwise it does not get interpreted right. Plus, you need to make sure your normal map was rendered with your smoothing correct otherwise if the smoothing changes between Blender and UDK the normal map won't match.

          Comment

          Working...
          X