Announcement

Collapse
No announcement yet.

LIGHTMAP import problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    LIGHTMAP import problem

    Ok.Im prety shore ive done my homework but in 2 words here is the problem.My model in maya has a correct uv chanel for texture and a second one for lightmap.The normals are set correct with(the soft/hard edges option) and if i import the model without the light map(respecting the smoothing groups)everythink looks fine.If i import the model with the light map chanel it looks bad.Im pretty shore its a light map issue but im not shore what am i missing and im stuck.Here is a screenshot to explain.

    http://imageshack.us/photo/my-images/9/lightmap.jpg/

    Thanks again.

    #2
    Hey i see your using maya also, im having problems with my lightmaps and i get seams on them.
    Can you tell me how i can get rid of the seams in maya what sort of settings do i use while uving and also in uv set editor do i do anything?

    Comment


      #3
      This is obiously a smoothing issue. Looks like most of your smoothing group / hard edges information got lost.
      I really don't know how a second UV channel (that's it in fact, you don't export lightmaps, those getting rendered while a light rebuild) should affect the mesh geometry.

      Comment


        #4
        Lightmaps do get exported but indeed this looks like smoothing group issue. when you import your mesh try to turn on the option called "Explicit normals" see what happens

        Comment


          #5
          Hello and thanks for trying to help me.Ive been importing en exporting like crazy for the past 2 hours in difrent combinations.Since i did everything ok those smothing groups are geting lost i think because of the fbx.Im using maya 2012 x64 and so no actor x for me since epic decided to go and use fbx as standard.I think that the only way for me to see if this is a fbx problem is to export the mesh as another format but as i sad no actorx and i guess no .ase.Ive already used the fbx so any ideas what can i use instead as a format to export the mesh?

          Strmix.My udk version is newer and i dont have the Explicit normals option.I did use the import tangents but no luck.
          I guess its gona be a loong day tomorow...

          Comment


            #6
            I think i found the problem.Its very stupid but not so easy to fix.I didnt said it at the begining but when i finished my low res mesh in maya,i than maid only the uv map chanel for the texture and exported the model as a fbx just to see it in udk (and in the fbx exporter i have the options of smoothing groups turned on).Everythink is ok for now.When i decided to make the second uv chanel for the light map i imported that fbx file back in to maya and all the smothing groups where fine just as i made them.I remember this thing hapening to me years ago and i think its a visual bug that was never solved in maya(fbx,obj,etc)When you finish creating the smothing groups for a model in maya and export it as a fbx for example and than import that same file all looks fine,but those smoothing groups i think are locked and visualy they inherit the old tweaked look but they are all hard actually.Thas whay when you export the second time the same file you get this bad smothing groups representation in udk but in maya they look fine for the eye.So the only way i guess is once you finish your model make shore everythink is finished and only than start to adjust the smooth groups.Adleast in maya...
            There is an option in maya to unlock the normals but once you do it you get only hard edges.Not the tweaked smoothing groups you did earlier.

            In the end i guess its not a lightmap issue.I do have a file of the model without the second uv chanel and it looks nice in udk and the only think i can do is try to import a lightmap mesh fbx in the unreal statick mesh editor but everythime i try to do it i get the mesage:

            Some statick meshes failed to import ore provided warnings.Check the log window for detail.

            By the way where can i find the log window?Its been some time since i used udk and forgot it.

            Comment


              #7
              Ok,its 1.52 at night and just manage to fix everything.I used and old fbx file of the mesh with the correct smothing groups and imported it in maya with the option unlock normals.Than using the transfer atributes managed to copy the 2 uv chanels from the new mesh to my old one,exported it again and its all fine now.But for the future i guess i shall look for a script that unloks normals without destroing the work.I hope that it exist.

              My turn to help now.Stimix,i saw you first mesage at the begining of the thread.Can you post a screenshot of your problem?
              I guess we can share my thread xd.

              Comment

              Working...
              X