Announcement

Collapse
No announcement yet.

normal maps and seamless textures?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    normal maps and seamless textures?

    So I've been having this problem when i make normal maps
    I don't use zbrush to sculpt my models to make normal maps, I use a gimp plugin because I want the effect normal maps to give to be based off the texture.
    Any ways it seems like when I add a normal map to the material seamless textures break and you can see the seam. In this case the textures for the barrels are actually just 1 solid color.
    I tried to play around with this, making the barrels the solid purple color but it seemed to have no effect at all. i tried remove the purple and leaving part of the defuse map there, when i did that all hell broke loose with the texture
    then I tried to completely remove the white so it was just transparent. Now this worked but it was extremely dark compared to the rest of the model. So then I tried white instead of transparent and that gave me the same problems i had with just leaving the defuse parts in.

    Hope fully I made my self clear. Thanks for reading.


    With out normal map

    This is what happens when I add the normal map

    diffuse texture

    normal map

    #2
    I am almost 98% the issue you have is due to smoothing groups, not normal map.

    Comment


      #3
      I'm not sure what a smoothing group is, Is it a UDK setting or an export settings? (I use blender not 3dmax)

      Comment


        #4
        Originally posted by Graylord View Post
        I am almost 98% the issue you have is due to smoothing groups, not normal map.
        Yep I agree with you, but the OP really need to go back to the basics of texture maps.

        Comment


          #5
          You can PM me if you want me to explain it to you and resolve your problem.

          Comment


            #6
            Originally posted by timmie124 View Post
            I'm not sure what a smoothing group is, Is it a UDK setting or an export settings? (I use blender not 3dmax)
            Smoothing groups are basically a bunch of faces that should be shaded as 1 big faces. If you had a basic square and subdivided it so there are many smaller faces for each side of the cube. You then set each "smaller face" as it's own smoothing groups, you would get a bunch of weird shadowing on each side of the cube.

            If you were to set each side of the cube as a smoothing group, it would then shade it as 1 big face. Assigning faces to smoothing groups differ based on how you export them mesh. I use the UT 3 editor and MCampagnini's ASE exporter and that uses hard edges to determine smoothing groups.

            As for creating normals, while you can do it with GIMP plug-ins, you are not going to get good results with diffuse textures that are that simple. If this is just a test texture, then ignore what I just typed.

            Comment


              #8
              Thanks for the help tigerija, but after playing around with the model for a while trying to get smoothing groups to work, I discovered it was nothing to do with smoothing groups. It was the way I was importing the texture, under compression settings I had to chance it to TC_Normalmap, I still don't know if this is right or not but it has fixed the problem. I tried it on an other couple models that I was having similar problems and it solved the problem.

              Comment


                #9
                So is your problem solved or not?
                Problem was in compression? Yea you have to pick specific one for Normal maps.

                Comment


                  #10
                  yeah the problem is solved, I didn't know I had to choose what type of texture it was before importing it to udk

                  Comment


                    #11
                    You should also make it so that seam is facing the building so it's less noticeable.

                    Comment

                    Working...
                    X