Announcement

Collapse
No announcement yet.

Particle System lighting issues! Need help

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Particle System lighting issues! Need help

    I've just created a particle system using my own materials. The material also has an opacity channel. I can get the particles to appear normally in unlit mode, but when I go into lit mode, it just loses all colour and turns black. What do I need to do to make particles accept lights?


    These bloodcells are supposed to be red...

    Thanks

    Edit: Well, after some serious detective work, I've sussed it out.

    For anybody else who might have this problem, heres how you fix it:-

    1. Go into the properties of the emitter (not "edit with cascade")
    2. Goto the LOD section and open settings, then tick lit
    3. Open the lighting settings in properties, and tick "accepts lights"

    Note: If you dont have "lit" ticked in the LOD settings, you wont even be able to tick the lighting options.

    Now theres ANOTHER problem with the particle system LOL. For some reason, the further "up" you point the camera, the darker the particles become. So in otherwords, if your looking right down at them, the brightness is full, but if your looking right up at them, the brightness is at 0%.

    Does anybody know why this happens, and how to stop it from happening?

    #2
    Trying setting the material as Unlit with the diffuse texture in the emissive slot instead of the diffuse slot. This should solve the problem of the particles being black when in lit mode, also if this is going to be used in a game setting having all the particles except light will most likely chug the engine.

    Comment


      #3
      I forgot to thank you man, it worked. Cheers!

      Comment

      Working...
      X