Announcement

Collapse
No announcement yet.

First successful import into UDK

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    First successful import into UDK

    Finally after one week of searching and trying to get the ASE exporter for blender 2.59 to work I gave up and then figured that UDK can use fbx formats so I exported my models from blender as .fbx files and imported them and hooray it worked but I did read a post somewhere that fbx formats cause some smoothing issues I don't know if that's true but I do find my models a bit funny looking especially the m16.












    #2
    Congrats on getting your models into the editor. I use the UT 3 editor and use MCampagnini's exporter (version 1.3.0), which should work great with Blender 2.59 (with the exception of vertex painting, as far as I know).

    That being said, I have a specific Blender tutorial list for Blender 2.59 and how it relates to modeling for the Unreal editor. I also have a page that covers the 2 exporters, though I haven't tested with the 2.59 version of FBX and UDK.

    Now it's time for you to get some proper textures on those meshes!

    Comment


      #3
      Yup! Texturing time soon! But before that I'm have a tutorial about modelling a tree i'm going to try and model a tree without the speedtree modifier because it's the same as learning how to count before using the calculator if you know what I mean I'll check your tutorials out too! About the MCampagnini's ASE exporter I tried that but didn't manage to get that to work yet. So that's why I decided to try fbx for now.

      Comment


        #4
        Regarding MCampagnini's ASE exporter, there are certain requirements. If you check that second link, I cover the requirements, which may not be obvious when you first use it, but are easy to understand. He has smooth group supports by marking edges as sharp.

        Comment


          #5
          Sweet then I'll try again I hope it works this time. Ah that I read that your requirements how to use the ASE exporter but it's not that, that's my problem it that I can't get the script to show up in blender for some reason? I put the python script in this: C:\Program Files\Blender Foundation\Blender\2.59\scripts\addons and then opened up blender and checked the export menu and it didn't show up I was also told it was in user preferences add-ons or something I did find it there and when I clicked install addon it didn't do anything but after that it started giving me this in the preferences menu: Multiple addons using the same name found! Likely a problem with the script search path.

          Comment


            #6
            Originally posted by Dagon19 View Post
            I put the python script in this: C:\Program Files\Blender Foundation\Blender\2.59\scripts\addons and then opened up blender and checked the export menu and it didn't show up I was also told it was in user preferences add-ons or something I did find it there and when I clicked install addon it didn't do anything but after that it started giving me this in the preferences menu: Multiple addons using the same name found! Likely a problem with the script search path.
            Make sure you have the 1.3.0 version (which is works for 2.59.

            I have always opened up the User Preferences, select the "Add-Ons" tab, then select the "Install Add-On" button, find the file, then select the "Install Add-On" button from the file browerser menu. After you do this, it's added to Blender, but not activated.

            While still in the Add-Ons section, select the "Import-Export" button on the left and make sure the "Community" button is checked. You should see his script as "Import-Export: ASCII Scene Exporter". Select the little box to the right and you are good to go.

            I think you may need to save your User Preferences so it's always enabled? I always do this when I make a change that I want to keep as a default setting.

            Comment


              #7
              I did what you said and it seems to be working now it showed up nicely and I've saved it as the default setting except I did try and test it and export just a default cube but it didn't appear on the desktop? Maybe it's because I didn't uv unwrap it etc

              Comment


                #8
                Originally posted by Dagon19 View Post
                Maybe it's because I didn't uv unwrap it etc
                UV Wrapping is required for the export to work (since it's needed for all meshes). You don't need to unwrap UCX primitives though.

                Comment


                  #9
                  Is the soldier a skeletal mesh or static?

                  Comment


                    #10
                    Static mesh no rigging as of yet still need to learn how to use UDK better.

                    Comment

                    Working...
                    X