Announcement

Collapse
No announcement yet.

Wierd shadows when using custom UV map

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Wierd shadows when using custom UV map

    Hi, I have a problem.

    The first picture shows a model with a basic color as diffuse with a normal and specular map, it uses a UV map generated by UDK.

    The second picture shows the same model, this time with my own UV map made in 3ds Max. Once compiled you can clearly see a problem with the shadows.





    What I've tried in order to solve it:
    - check for overlapping UV's
    - check for inverted faces
    - give the bottom part more resolution on the UV map

    Does anyone know what I'm doing wrong? I've made quite a lot of models for use in UDK but only a few of them have this problem, the only solution I have found is letting UDK generate a UV map.

    Thanks

    #2
    Probably your UV map generated in Max doesn't have enough padding between the UV charts to prevent bleeding artifacts.

    http://udn.epicgames.com/Three/LightMapUnwrapping.html

    Comment


      #3
      The only thing I'm seeing is that maybe your normal maps are rendered incorrectly, you can see segments of the model in the normal map so maybe you rendered them with different smoothing settings on your model than what you're using in UDK.

      Comment


        #4
        Originally posted by Count_de_Money View Post
        Probably your UV map generated in Max doesn't have enough padding between the UV charts to prevent bleeding artifacts.

        http://udn.epicgames.com/Three/LightMapUnwrapping.html
        Interesting read, it claims it's better not to make seperate objects and merge them together (I tend to do that to save on tris). The bottom part of the street light is a seperate object merged to the top side, maybe that's causing some problems. I'll re-model the part and check it out.

        Originally posted by darthviper107 View Post
        The only thing I'm seeing is that maybe your normal maps are rendered incorrectly, you can see segments of the model in the normal map so maybe you rendered them with different smoothing settings on your model than what you're using in UDK.
        What exactly do you mean by 'smoothing settings' in UDK?

        Thanks

        Comment


          #5
          They probably meant smoothing groups in Max. If a mesh is not smoothed properly, it's often a cause of lighting artifacts later on.

          BTW - what's the lightmap resolution on this mesh (in UDK)? When you open the mesh in the content browser, it's a property up there in the list on the right. You can spend a lot of time laying out a nice UV set with proper padding etc, but if the lighting for it gets baked onto a 16x16 pixel lightmap, you're bound to get shadow bleeding right.

          Comment


            #6
            Originally posted by 1/2Hawk View Post
            BTW - what's the lightmap resolution on this mesh (in UDK)? When you open the mesh in the content browser, it's a property up there in the list on the right. You can spend a lot of time laying out a nice UV set with proper padding etc, but if the lighting for it gets baked onto a 16x16 pixel lightmap, you're bound to get shadow bleeding right.
            128x128 which is pretty high for a relatively small model.

            Comment


              #7
              Erm...? It is skinny true, but how tall is that thing? (Cant tell from the image). I don't imagine you'd stretch a 128x128 texture on it and say it was high. Ex: If it's 16 ft tall, then you only have 8 pixels per foot maximum of lightmap resolution which is pretty bad actually.

              The real question though is would it fix the problem... Change it to 512 and redo the lighting. If you still see artifacts then we gotta try something else to fix it. If it does fix it, then you can balance different values til you find something suitable.

              [Remember that these values are opposite for BSP and static meshes ... so for statics, the higher the value the more resolution you have and the more memory you consume].

              Comment


                #8
                It could also be normal map influence on the baked lighting (in world properties). I've noticed tweaking this value helps in objects that have heavy Normal Maps (read higher detailed maps).

                Comment

                Working...
                X