Announcement

Collapse
No announcement yet.

Blender 2.57 ASE export

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    A question I don't think that's been asked yet... Is it possible to add the export command to the Object Mode tool shelf? Blender Cookie did a tutorial on how to customize this too shelf and when I go to export a bunch of models, it would be nice to use this shortcut.

    Comment


      Originally posted by Odedge View Post
      A question I don't think that's been asked yet... Is it possible to add the export command to the Object Mode tool shelf? Blender Cookie did a tutorial on how to customize this too shelf and when I go to export a bunch of models, it would be nice to use this shortcut.
      There are too many export options to simply use a shelf. A quick export button would be feasible, but I'm not convinced it's worth my time investment!

      Edit: There are also context sensitive areas in Blender that you have to jump through hoops on. Cursor not on the 3d viewport? You can't perform function A.

      Comment


        Originally posted by MCampagnini View Post
        There are too many export options to simply use a shelf. A quick export button would be feasible, but I'm not convinced it's worth my time investment!

        Edit: There are also context sensitive areas in Blender that you have to jump through hoops on. Cursor not on the 3d viewport? You can't perform function A.
        Thanks for the reply... I wasn't really asking you to add it, just wondering if I could add it to a shelf easily.

        Comment


          I am having some problems. Whenever I try to export my mesh (a deco box mesh) some of the normals get flipped. So I've tried going through each face and reverting them to the correct orientation, i.e. flipping normals, but the problem persists after export. Not sure if it matters, but after export it sends me back to edit mode with edge select being the default. I have tried another exporter (fbx) and this does not happen - no faces inverted, reverts to object mode. This happens for both the latest exporter and the former 2.01?

          Before & After export (i changed to face select mode [export] to make the comparison easier).


          I can offer the mesh if that helps but I'm out of ideas, any help would be appreciated.

          Comment


            Achernar,

            Are you flipping the normals manually or with the automated command? Are there duplicate vertices that might be causing a problem with extra faces? Can you tell I am guessing?

            If McCampagnini doesn't respond, I can test on my machine tonight. Just email it to me. or PM me.

            Comment


              Well both actually. I found I needed to resort to manual as the automated version doesn't do a very good job. Not sure how significant that is? Never the less the exporter does have a lot of trouble with this mesh.

              Check your PM. Thanks for checking it out.

              Comment


                Have you tried to turn off the export option that says "Recalculate Normals"? I have also had trouble with the Blender recalculate normals algorithm before. Feel free to send me a PM with the model download link if the reclac normals option doesn't do it.

                Comment


                  Achernar, I got your model and tried recalculating normals on the outside, but it didn't work. I then tried flipping them one by one (didn't do all of them) by going to Mesh > Normals > Flip Normals. I MCampagnini's suggest and left "Recalculate Normals" unchecked. Seems to work fine for me. I am using Blender 2.64 + latest ASE exporter.

                  Achernar, check your PM inbox as well.

                  On a side note... Blender 2.65 was just released.

                  Comment


                    @MCampagnini
                    Thanks for the suggestion. This has helped alot, so glad it was a simple fix.

                    @Odedge
                    Thanks for taking a look and we managed to get to the bottom of it.

                    Already got it installed

                    Comment


                      I'm not sure if anyone else has the same issue, but all of my meshes end up really large upon import to UDK. The default blender cube that the .fbx exporter reads as 2*2*2 UU is read as 32*32*32 UU by the .ase exporter. It's just a lot of extra math to have to do to figure out the size of my object prior to export, otherwise I haven't had any issues with it.

                      Comment


                        Originally posted by Hellclown View Post
                        I'm not sure if anyone else has the same issue, but all of my meshes end up really large upon import to UDK. The default blender cube that the .fbx exporter reads as 2*2*2 UU is read as 32*32*32 UU by the .ase exporter. It's just a lot of extra math to have to do to figure out the size of my object prior to export, otherwise I haven't had any issues with it.
                        It's because the ASE script has a default scale of 16, which explains why it's 16 times bigger. I build all of my meshes to the exact size they will be in the editor, so I have changed my default scale to 1.0. Check this page (under the scale section) for more info on how to do this.

                        I also set up my Blender grid so it never goes below 1. This way, if I am making a more "technical" mesh, I know it will always be snapped to the grid. If I am making a more organic shapes (like a rock), I just disable "snap to grid".

                        Comment

                        Working...
                        X