Announcement

Collapse
No announcement yet.

MAX > UDK textures

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Have you actually imported the texture into UDK and made a material there?

    And I'm not talking about when exporting the model.

    Leave a comment:


  • replied
    Another great tool for those wanting an alternative to painting with UV maps is to use this: http://pixexix.sophiehoulden.com/ which allows you to paint faces on the fly and see the results in real time.

    Leave a comment:


  • replied
    If U were using maya, I'd tell U that the face might be inverted and U need to reverse normals...But in Max, cant be so sure

    Leave a comment:


  • replied
    Here, see this thread http://forums.epicgames.com/showthre...9#post28080559 and you'll see that I posted that it does in fact work, and how.

    You may have some of your material IDs done incorrectly, or you may be using materials which are incompatible with UDK, like .jpgs.

    Leave a comment:


  • replied
    Here are two screenshots - one that is from MAX, showing the model with textures appropriately fitted out and looking ok.... then one from UDK showing the hole in the side of the ship and at just behind the tower....

    ....tried virtually every import option within UDK import options, to no avail. When I reload it back into MAX, it seems good.. :S



    Leave a comment:


  • replied
    Right, I've imported another model....
    ...when I import it via saving as .FBX then there is a part of the mesh missing; however with ASE it's fine but does NOT import ANY of the materials or entries for texturing. This one is more unusual that the previous model though as it seems to be associated with the mesh specifically as there is gaps in the model and it's not texture/material specific.
    Weird....

    Leave a comment:


  • replied
    Update....
    I've now removed all extraneous textures - we had a race-set of textures applied and some where unnecessary. I've now reduced it and whilst I admit, it still has too many, it now has 18 entries within MAX and 17 when I bring it into UDK via .FBX and the missing 18th is see thru and not selectable.
    If I export via .ASE then I get ONE material/element within UDK and therefore I can't paste the new materials (after making them) via material parts...

    Any help?

    Leave a comment:


  • replied
    I'm still stumped on my import problem.
    It's a MAX model, that I simply save as an FBX file.... it is not specifically set up for UDK however it's for testing and such. It has numerous materials - however they'd be used across multiple objects....
    I export from MAX and then look at the model within Content Manager and the object has one of the materials missing.... as in where that material should be on the model there is geometry missing. Wherever the material would be applied - there's just empty space.... where am I going wrong if all the rest is correct?
    I've gone thru it all adding underscores so there are no spaces in any materials anymore and such...

    I now replaced the odd-acting material -in MAX- with the one adjacent to it that works fine and yet the mesh is still missing geometry at these points?!

    Any help - please?

    Must be something to do with the model itself.... I've edited the model now to change the material completely for a different one and still the gap.... is there anything specific I need to do to the model for export? All tutorials I've seen simply create and object and export it... I realise this is a far more complex model but there must be something I'm missing?!

    NOTE: When I export as .ASE the geometry is present... however, I lose all my materials.

    Leave a comment:


  • replied
    U need to have different materials assigned to the different parts of your mesh in MAX...before U export to UDK (e.g if U want the head and body to have separate materials in a character mesh, make sure U assign one material to the head, and another to the body in 3ds MAX). When U export your mesh to UDK, there should be 2 material slots in the Static/Skeletal mesh editor... Hope that helps.

    Leave a comment:


  • replied
    like i said the work flow is important, what type of mesh how many materials you have on it

    Leave a comment:


  • replied
    Whilst I'm sure it's my fault.... this is for sure.... I'm just curious as to why.... All I did was load in the mesh, then started adding the materials to it.... all the other materials were ok... except this one... which wouldn't even appear on the mesh.... Strange....

    Leave a comment:


  • replied
    It's what known as not setting your materials/mesh correctly, while i'll not explain fully here as i've no idea what your tring to do, staticmesh or skeleton mesh, 1, 2, 3, ... materials, there are quite a few tutorials out there which show you how to do it

    Leave a comment:


  • replied
    Also - I had about 10 material in the UDK... I quit, reset my PC, came back in and the materials were still there but without any textures again -?!?! Does anyone know why??? I'm clearly getting lost somewhere?!

    Leave a comment:


  • replied
    I have exported directly a model from our mod, just for curiosity - even though it uses multiple textures. I exported it as .FBX as this takes out all settings for textures and such, creating materials as well.
    Well, I did such and after creating the materials required it looks great - except one of the materials is missing. I reload the fbx into MAX and it looks ok - albeit grey - but within UDK there is one material that is not there and where that material belongs is just empty - leaving a gap in the model.... any ideas what is causing this?

    Leave a comment:


  • replied
    Apologies for the lack of search function... however the sarky message received was well worth the post anyway

    Can't say I understood it hugely.... however, it's given me a few words to search in help files :P

    Leave a comment:

Working...
X