Announcement

Collapse
No announcement yet.

Better blocking light with models

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Better blocking light with models

    How ?


    I have a light inside my model, but, as you can see, I have a lighting (under the red space) who must not be here...

    How to block the light ? Inside my model the light meet some face, so, I don't view how to make something betetr to fix this problem...

    #2
    Does your mesh have "cast shadows" enabled, in the same light channels as the light?

    Comment


      #3
      What do you mean by "light channel" ?
      (Yes my static mesh have cast shadows enabled)

      Comment


        #4
        No other idea ? It's a mesh problem or a level design problem ?

        Comment


          #5
          I'm not sure what I'm looking at in that picture. What is that red boxes supposed to be?

          Comment


            #6
            I made 2 schemas for better explain what I need :


            That I want.


            That I get.


            I try to active dynamic shadow, but I get the same things. I don't understand why...

            Comment


              #7
              What does the UV layout look like on the fireplace and are you using 2 UV channels?

              Comment


                #8
                Yes, I have 2 uv channels for have a lightmap.


                I hope it's readable.

                Comment


                  #9
                  It's not just the sides. The bars in front are not casting shadows either. It seems to me that either the 2nd channel is not being read, the lightmap resolution is too low, or something wrong with your light setting. What does it look like in the static mesh editor window? Does it say it reads 2 uv channels and that it's using channel 1 for light map? And you should have 128 or higher for resolution. Also that the light radius is adjusted properly to cast sharp shadow and what kind of light are you using?

                  Comment


                    #10
                    It's not just the sides. The bars in front are not casting shadows either.
                    It's because they are no faces :



                    My mesh and light settings :

                    LIGHT



                    STATIC MESH

                    (I change the ground lightmap for better look the lighting)

                    Comment


                      #11
                      Well, does the side surfaces have inside wall? And can you double click on the static mesh in content browser and show me the static mesh editor of that object?

                      Comment


                        #12
                        It's a Wood stove, I want to make a fire with wood inside. And use a light which casts shadows. The source light is the fire.

                        Mesh editor :


                        I looked again and again, I have no reverse faces.

                        Comment

                        Working...
                        X