Announcement

Collapse
No announcement yet.

Another UV-mapping question...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Another UV-mapping question...

    Another UV-Mapping question. (New to 3d modeling and UVs have become my personal hell). Anyway...

    So, let's assume that we have a simple wall mesh. If I apply and an Unwrapper on it and the "flatten mapping" function as usually recomended, each one of its 2 sides will devoure half of texture's space and as a resault each side would use the half of its pixels...
    Instead... If I could possibly set the UVs so that both sides use the entire texture since they could use the same surface, each one would use more pixels and as a resault I would get better looking textures applied on it.
    So, the first thing I tried was to overlap those two surfaces and weld them together. UDK though still pops up that "verticles count ratio" error when I import the model".
    Would that affect in any way games performance and if yes, is there any other technic to apply the same texture at both sides?

    Thanks for your time and sorry for the noob questions.

    #2
    Rather than "flatten mapping", select both sides of the wall and choose "planar" in the Unwrap UV modifier options., select either x,y, or z axis to get the best alignment. both sides of the wall (assuming it is symetrical) should be lying over eachother. then just scale to fit! no need to weld verticies.
    otherwise, you could delete half of the wall, map the UV, collapse, then add a symmetry modifier.

    Comment


      #3
      Thank you for the info!

      I still wonder though if that "vertex count ratio" means something for game's performance or if it is there just to say "hey ThePriest909, you suck in UV mapping".

      Comment


        #4
        I think that if you are getting the "vertices count ratio exceeds...blablabla" error on import, it just means that UDK is re-triangulating your mesh. It just means that you were working on an editable poly or mesh that has quads. unreal works with tris. so if you have a mesh that contains quads, udk will recalculate it into tris. you can test this by having your mesh in 3ds max, add the modifier "turn to poly" (don't use "convert to poly" from the contextual menu) and near the top is an option to limit the # of sides that the polys will have. set it to 3 and check the box. this should give you an editable poly of tris. Try exporting this mesh and importing it into UDK and see if you still get the error message.

        You may have to tweak your smoothing groups after converting to tris.

        Comment

        Working...
        X