Announcement

Collapse
No announcement yet.

SK Mesh export problems, help!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    SK Mesh export problems, help!

    I'm trying to export a character mesh from 3ds max that has been rigged to the UT3 skeleton. I can't collapse the skin modifier to the mesh, and when i export, I get the "Unmatched node ID" error. if i bring the mesh into udk, the skeletal mesh viewer lists old element and group names that had since been attached to the main mesh. For example, it's recoznizing all of the hair planes as bones. None of the bone names show up, tho i'm pretty sure the bones are being exported and imported by the change in poly count.

    What am I doing wrong? There are no longer any groups in the mesh itself, so i find it strange that the udk can read the names of them.

    #2
    you need to attach all the geometry into a single mesh then skin and export

    ps if you google the error you get some info

    Comment


      #3
      All of the geometry, as in the biped and ut3 skeleton? Otherwise, my mesh is already attached.

      Comment


        #4
        ok right click then click on unhideall, delete any extra meshes and export your mesh

        Comment


          #5
          That did the trick, thank you Geodav!

          Btw, is there I had to delete the biped or else all of the biped's bone neames showed up instead. is there anyway to hide geometry during export?

          Comment


            #6
            watch my UT3 charater videos, they show you how to set it all up, you don't need to delete the biped just need to set actorx properly (cull unused bones)

            Comment


              #7
              Ok, I looked at your tutorials, Geodav (very nice, BTW). I think that I am doing everything properly, however, I cannot export my mesh with the proper tree names without deleting the biped. I guess it isn't a big deal, as I can just delete the biped, export, then undo until I get it back, but since you say that it is possible to export without deleting it, it's going to drive me nuts until i figure it out.

              I have my mesh, rigged to the UT3 skeleton (b_root, etc) via the skin modifier and vertex weighing. I have loaded an animation file to test out the rigging in different positions/contortions. Could this be my problem? As it is, I get the same result exporting from figure mode as I do from exporting out of figure mode. I've set up the actorX export options as you've recommended, and played around with the settings (cull unused dummies makes no difference). I've tried hiding the biped, the skeleton, both, none, selecting the mesh, selecting all, all textured and not, all skin types, etc.

              Comment


                #8
                i can only advise what works for me,just had a brainwave carefully go through your biped bones to see if one has had a material applied to it, if that doesn't help you could try starting with a clean UT3 rig

                sorry i can't be more of help

                Comment


                  #9
                  I selected all of the biped bones, and under object properties, it says that no material is applied. I would start with a clean UT3 rig, but i'm already on my 3rd clean rig. When I check the scene info with actorX it tells me:

                  Number of Physique 1
                  Total geometric 139
                  Bones in main skeleton 82

                  skin

                  faces 0
                  Verticies 0
                  Skeletal elements linked to skin 0
                  Total number of links to skin 0

                  Skeleton

                  Total elements 82 Geom/biped bones 69
                  MAX bones 0 Dummies 13

                  My biped is 83 bones. The UT3 rig is 68 (I deleted the shoulderpads). My mesh is a single mesh.

                  Am I supposed to link my main mesh to b_Root, or something? Or the UT3 skeleton to the biped? Any linking supposed to be going on?

                  Comment


                    #10
                    to be honest i'm a bit lost, you have more bones than me and you still showing the dummies, any chance of you uploading the file somewhere and pm'ing me the link so that i can take a look

                    Comment


                      #11
                      would you like the whole .max file?

                      Comment


                        #12
                        yes please

                        Comment


                          #13
                          PM sent.

                          Thanks for your help!

                          Comment


                            #14
                            I came across this on another forum:

                            you must collapse the trajectories of the epic skeleton. This is done by selecting all the pieces of the epic skeleton then go to Motion tab -> trajectories -> collapse under "collapse transform"

                            With this, I can delete my biped without losing my pose. Seems to export and import properly now.

                            Comment

                            Working...
                            X