Announcement

Collapse
No announcement yet.

texturing a model in the UDK from 3ds max

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    texturing a model in the UDK from 3ds max

    I've exported my model with a UV over all objects. I then take it into the UDK to try and apply the diffuse texture that I baked with "render to texture" but it looks like it's trying to tile each face with the texture. What am I doing wrong?

    Here's the texture as it looks in 3ds max 2010



    And here is how it ends up in the udk.


    #2
    It's possible that the material you have applied on the mesh inside Max when you export the model has a tiling setting, inside the material. This will actually cause the UV to be tiled on export.

    If you go in your material, into the diffuse channel check on top there is Offset, Tiling.. etc. Check that the Tiling is 1.0 for both U,V.

    Comment


      #3
      I changed the tiling settings but it didn't help. I went and tied them all together as one object and did the UV map, model export, and render to texture from that after flattening the UVW map but that didn't help either. I do appreciate your help though.

      Comment


        #4
        I can take a look at the file if you want to post it. Just the max file needed.

        But if you want to try. Make a brand new Standard material so it's just a gray material sphere. Apply that to your model before you export. This just to double check and make sure it's not the material. It's impossible to tell what you did in your whole procedure if something cause problems there. If this doesn't help then there is another problem which I can't really guess so would probably have to look at your max file to make sure if the problem is from max or not.

        Comment


          #5
          I've had similar problems sometime, I fixed it by exporting the mesh from max as .obj and reimported it back. Then I redid the UV map. Though that was because I tried exporting an instance of a mesh.

          Comment


            #6
            ASE exports is dodgy. It actually depends what you have in the scene and what materials are applied to the things in the scene. Even if you export a selected mesh only. It just needs to be handled with care, clean scene and materials etc.. then there won't be problems. I also recommend a clean stack. Basically the scene needs to be at it's minimum needed for the current mesh you want to export. It's the safest way to deal with ASE exports.

            Comment


              #7
              Normally if ASE doesnt work for me (uv and material not exporting) , i will switch to Collada NextGen exporter

              Comment


                #8
                http://filesmelt.com/dl/metalpile.max here's the file if it helps. Please try and ignore the fact that it looks bad and that my technique (or lack thereof) should warrant a death sentence. I'm just trying to get this to work for the future. I'll start working on some of the other remedies on my own and reply if anything works. If I say nothing, nothing I tried worked. Thanks all

                Comment


                  #9
                  Ok, just something else to look at is your channels. You have a channel 1 that you unwrapped and then your RTT setting creates and uses channel 3. You should be using channel 1 al through the RTT process.

                  If you want to use different kind of UV on the mesh and RTT to another set of UV, then you have to use channel 1 as your "final" UV and you can use any other channel as your mapping UV's. If that makes sense.

                  Bottom line here is you need to set your RTT UV's to use channel 1 and don't have it auto unwrap the mesh again.

                  Comment


                    #10
                    Erm... I'm not sure what an RTT uv is exactly. I tried googling it but nothing useful game up. Could you explain it to me? I apologize for my ineptitude.

                    Comment


                      #11
                      He is regarding to "Render To Texture" in 3dsmax.

                      Comment


                        #12
                        Oh. Well that makes sense. Thank you :P

                        Comment


                          #13
                          Yes, I'm sorry.. I should have mentioned that. Force of habit to abbreviate..

                          Comment


                            #14
                            THANK YOU! I am in your eternal debt. That thing about using channel 1 worked perfectly.

                            Comment

                            Working...
                            X