Announcement

Collapse

The Infinity Blade Forums Have Moved

We've launched brand new Infinity Blade forums with improved features and revamped layout. We've also included a complete archive of the previous posts. Come check out the new Infinity Blade forums.
See more
See less

Maya Skin File Creation Error

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Maya Skin File Creation Error

    Title will give away my problem I suppose... But I'm working on a simple weapon in Maya and when I go to export I get "Skin File Creation Error". These are the steps I took to attach the Skel to the Mesh.

    Selected root bone
    Selected mesh
    Went to skin -> Bind Skin -> Smooth Bind -> Options
    in options I set Bind To: Selected Joints

    Then I tried to export. Did I miss something?

  • #2
    What is the whole error message?

    Comment


    • #3
      Skin File Creation Error then Skin Save Error

      Thats it

      EDIT: Uploaded a vid of my process. http://www.youtube.com/watch?v=r5HK0bW0OzQ

      Comment


      • #4
        You have a dirty construction history on your mesh, delete history and try again.

        Comment


        • #5
          Edit -> Delete By Type -> History right?

          Did that and it still gives me the errors.

          Comment


          • #6
            Have you tried to just Bind Skin without setting specific joints and then skinweight afterwards?

            Comment


            • #7
              Well actually I didn't realize that your export folder must exist before you export...

              Comment


              • #8
                LOL, **** happens! Good luck with your weapon.

                Comment


                • #9
                  Yeah, stupid little mistakes are always fun... But now I'm having another problem.

                  I added some moving parts to my mesh and all the anims and what not work perfectly in Maya (I'm using AXtended by the way, its awesome) but once I get the mesh and anims in to the editor I only see the basic movements. The slider on the top of the gun doesn't move, the clip doesnt fall out, etc. but the anims are all there because there is SOME movement. Do I have to combine all polys into one mesh before I bind it to the skeleton or... I don't know. Any thoughts?

                  Thank you very much by the way for your time Denny. I really appreciate it.

                  Comment


                  • #10
                    Did U uncheck BRotation only: under the Animation tab?

                    Comment


                    • #11
                      What Kelt'ar said, you need to uncheck that option as animations in Unreal only allows rotational motion by default as an optimization.

                      Comment

                      Working...
                      X